PDA

View Full Version : Problems with Content Creator Plus



xavi38
January 23rd, 2010, 11:23 AM
Hello Everyone:
First of all excuse me for my bad english.
Recently i've installed Trainz 2009 in my computer running Windows Vista.
I has to change permissions on TS2009 folder to can save mi creations, cause I can not save it before.
But now when I try to run Content Creator Plus Windows tell me can not start the program.
I don't know where is the problem.
Can everyone help me.
Thanks so much.

DonZer63
January 23rd, 2010, 11:44 AM
Moin,

Go into the trainz folder, right click the CCP icon and choose "open as administrator". If the error occurs once more, ignore it and wait a little time. Because CCP need any time to open the asset, windows "think" the program is wrong and sends out an error.

Hope that helps?!

xavi38
January 23rd, 2010, 03:37 PM
Hello again:
I,ve tryed what you tell me, but not runs, and appears the message " CCP.exe stops to run. This program do not run correctly by a problem. Windows will close the program and notyfy to you if exists any solution." And just has a button that tells "Stops program".
Thanks for your idea, but any other idea?
Thanks so much.

rweber95
January 23rd, 2010, 10:09 PM
Run TrainzDiag.exe (in the TS2010\Bin folder) and see if OpenGL passes all tests. It's required for CCP.

Bob

Irving
January 23rd, 2010, 11:32 PM
Xavi;

Since all the Auran files are under the Program files directory, they are by default writeable only by the Administrative user.
Try the following possiblilities:


1:Add your user ID to the Admin group.

2: Open the properties of the Auran folder and the Share tab. Share the folder as the help message indicates (Move it to allusers/documents).

3: Since you messed with the permissions on the program files I assume you know about NT Permissions, so add write permissions for your user id.

4. Run the program logged in as the administrator. (THIS SHOULD BE #1 not 4)

IF all else fails, back up your local folder and remove the program and install it again, copy back you local directory and run it as administrator.

My understanding of Windows XP (and VISTA?) is that user data file are supposed to be installed under the user's My Documents or shared in the All users Documents. Think of MS Word which creates your documents in the users folders. Auran is the only software house I know of, which does not follow this current requirement. Maybe they assume that all PC owners never create useer ID's and login as administrator with out a password. I find most people do this.

I will watch for corrections to my post, thanks.
Irving

xavi38
January 24th, 2010, 04:36 PM
Hello Again:
Bob, I've runned Run TrainzDiag.exe and OpenGL it's OK. Thanks.

Irving, Thanks too for your response, but I've just started with TS2009, and I don't have enough knowledge about it now.
I've think than before create any contents better know all secrets of TS2009.
Thanks for all, but I prefer know how runs TS2009 before reinstall, and try anything else.
Thanks for all you help, and excuse my bad english again.
Thanks so much.

mutanay77
May 15th, 2011, 07:18 PM
Run TrainzDiag.exe (in the TS2010\Bin folder) and see if OpenGL passes all tests. It's required for CCP.

Bob
i tried that and OpenGL failed, and once the test is almost done the TrainzDiag stops working, as the same problem with CCP