PDA

View Full Version : Jerky movement Trainz 2009



ieaster
December 20th, 2009, 09:10 AM
Can anybody help
I have installed Trainz 2009 but get Jerky movement of trains. Despite changing resolutions this still happens. My graphics card is up to date and had all the boxes ticked with a green tick after installation. I also have Trainz 2006 installed and that runs perfectly on 1920 - 1080 resolution and there are no jerky movements. Has anybody else had the same problem and rectified it.

Thanks
Ivan

JCitron
December 20th, 2009, 11:44 AM
Can anybody help
I have installed Trainz 2009 but get Jerky movement of trains. Despite changing resolutions this still happens. My graphics card is up to date and had all the boxes ticked with a green tick after installation. I also have Trainz 2006 installed and that runs perfectly on 1920 - 1080 resolution and there are no jerky movements. Has anybody else had the same problem and rectified it.

Thanks
Ivan

What kind of graphics card do you have, and have you tried Open/GL instead of DirectX?

John

ieaster
December 20th, 2009, 01:06 PM
What kind of graphics card do you have, and have you tried Open/GL instead of DirectX?

John

My graphic card is a NVIDIA Ge Force 8400 GS and yes I am on open GL not DirectX

Ivan

JCitron
December 20th, 2009, 01:16 PM
My graphic card is a NVIDIA Ge Force 8400 GS and yes I am on open GL not DirectX

Ivan

Have you tried the latest drivers from NVIDIA and have you tried lowering the Trainz sliders. The 8400 is not as powerful as the 8800 series, but should handle the program fine.

Other things to check are the TrainzOptions.

Here's mine:

-DepthBits=24
-StencilBits=8
-Jet=bin
-cabinfov=60
-DefaultAutoMip=none
-DynamicVertexBufferSize=4194304
-DynamicIndexBufferSize=196608
-VBO
-uncached_alphas=1
-nolog

What are the specs on the rest of your system? Processor, etc.?

John

bobandwyoming47
December 20th, 2009, 01:54 PM
My graphic card is a NVIDIA Ge Force 8400 GS and yes I am on open GL not DirectX

Ivan
you need a updated motherboard processor

ieaster
December 21st, 2009, 02:53 AM
Have you tried the latest drivers from NVIDIA and have you tried lowering the Trainz sliders. The 8400 is not as powerful as the 8800 series, but should handle the program fine.

Other things to check are the TrainzOptions.

Here's mine:

-DepthBits=24
-StencilBits=8
-Jet=bin
-cabinfov=60
-DefaultAutoMip=none
-DynamicVertexBufferSize=4194304
-DynamicIndexBufferSize=196608
-VBO
-uncached_alphas=1
-nolog

What are the specs on the rest of your system? Processor, etc.?

John

Hi John
You might think Iam a bit dim but where do I find the specs you have given me above. I cannot find them in Trainz options? These are my computer specs : Intel (R) Core (TM) 2 Quad CPU Q 8200 @ 2.33 GHz
2.33Ghz, 4 GB of RAM, Physical Address Extension.

I have Windows XP home with SP3 installed.

Ivan

ColPrice2002
December 21st, 2009, 03:03 AM
Ivan,

Which routes does this happen with? Some of the routes are very high detail (and this can slow the frame rate) - try one of the older routes (yes, I know it's not as good graphically) - and see how that goes.

HTH
Colin

ieaster
December 21st, 2009, 04:22 AM
Ivan,

Which routes does this happen with? Some of the routes are very high detail (and this can slow the frame rate) - try one of the older routes (yes, I know it's not as good graphically) - and see how that goes.

HTH
Colin

It happens on all routes It looks like that I will have to stick with Trainz 2006 I get no problems with that. Its a pity though

FootplatePhil
December 21st, 2009, 05:51 AM
Another couple of things worth trying.

1, Try running using DirectX. Frame rates are usually faster in DirectX (although there maybe be other trade offs - but hey, it doesn't cost anything to try it)

2, trying adding the following line to the TrainzOptions.txt file (which you will find in your C:\Program Files\Auran\TS2009 folder - use Notepad to edit)

-framerate=23

This sometimes smooths out jerkiness if its due to sudden changes in frame rates. Experiment a little with the actual number. Please post back here if it works (or not !)

Phil

Dermmy
December 21st, 2009, 05:57 AM
It happens on all routes It looks like that I will have to stick with Trainz 2006 I get no problems with that. Its a pity though

I have the same problem - silky smooth graphics in 06, stuttery slideshow in 09. I have tried everything including 09 re-install (which seemed to fix things for a while, but back to the stutters now) a vid card upgrade (9800GTX) and a system RAM upgrade (4gig in an XP machine) to no avail. I gotta say 06 looks incredible now, but 09 pretty much unusable so back to 06 for me too...

Andy :(

tommy2tap
December 21st, 2009, 08:54 AM
just throwing in my 2 cents here. my computer is a little older and not as fast as some i've seen. matter of fact it was the least expensive model you could get at wal mart a year and a half ago. I started out with UTC and when i saw the stuff 09 was capable of i ordered a download. i do see certain advances even with my outdated computer but when i try to run the high frame rate routes ( anything from gfisher) i get the slide show effect. i also had issues with my trains disappearing behind objects that they shouldn't have ( power lines and the like) and some one suggested running in compatible mode instead of native mode and that helped. i still get slide shows on gfishers wonderfully detailed routes though.

ieaster
December 21st, 2009, 09:06 AM
Another couple of things worth trying.

1, Try running using DirectX. Frame rates are usually faster in DirectX (although there maybe be other trade offs - but hey, it doesn't cost anything to try it)

2, trying adding the following line to the TrainzOptions.txt file (which you will find in your C:\Program Files\Auran\TS2009 folder - use Notepad to edit)

-framerate=23

This sometimes smooths out jerkiness if its due to sudden changes in frame rates. Experiment a little with the actual number. Please post back here if it works (or not !)

Phil

Hi Phil
Tried running using Direct X and this seems to have rectified the problem. I am at present checking other routes etc. to see if all are ok. I did also add the framerate No. as well so perhaps they both worked together. Anyway so far so good lets see how I go. Many Thanks.
Ivan

FootplatePhil
December 21st, 2009, 02:50 PM
Hi Phil
Tried running using Direct X and this seems to have rectified the problem. I am at present checking other routes etc. to see if all are ok. I did also add the framerate No. as well so perhaps they both worked together. Anyway so far so good lets see how I go. Many Thanks.
Ivan

Your welcome ! And thanks for posting back. I have wondered whether this fix works for any one else but me (I have suggested it a few times now to people describing similiar symptoms, but got no feedback. It has worked on a number of machines I have personally tried it on)

Phil

SuperFudd
December 21st, 2009, 03:44 PM
Check with nvidea to see if you have the latest driver for your video card.

clam1952
December 21st, 2009, 06:53 PM
Your welcome ! And thanks for posting back. I have wondered whether this fix works for any one else but me (I have suggested it a few times now to people describing similiar symptoms, but got no feedback. It has worked on a number of machines I have personally tried it on)

Phil

Worked for me as well, before I upgraded my CPU, left in in for good measure anyway, think I probably got it got it from one of your posts, so thanks for that.

SnowSnake
December 22nd, 2009, 12:19 AM
Your welcome ! And thanks for posting back. I have wondered whether this fix works for any one else but me (I have suggested it a few times now to people describing similiar symptoms, but got no feedback. It has worked on a number of machines I have personally tried it on)

Phil

Thanks for the hint. I added the -framerate=23 and selected OpenGL - and now I have smooth motion, Phenom II 905e with a shiny new HD 5750 video card. I haven't found the magic settings for DirectX yet.

Dermmy
December 22nd, 2009, 03:48 AM
Sorry to rain on the parade, but I have tried DX and GL, fullscreen @ 1920 x 1080 and lower res, windowed at lower res.

I have always had -framerate=30 in Trainzoptions for every version I have.

ALL drivers are up to date, not just video.

With identical settings, fullscreen at 1920x1080 TRS06 is so silky smooth I can't believe it. 09 in Compatibility mode should be at least as good, probably better, but stutter clunk bang is all i get....

Andy :)

FootplatePhil
December 22nd, 2009, 05:04 AM
Sorry to rain on the parade, but I have tried DX and GL, fullscreen @ 1920 x 1080 and lower res, windowed at lower res.

I have always had -framerate=30 in Trainzoptions for every version I have.

ALL drivers are up to date, not just video.

With identical settings, fullscreen at 1920x1080 TRS06 is so silky smooth I can't believe it. 09 in Compatibility mode should be at least as good, probably better, but stutter clunk bang is all i get....

Andy :)

no rain here!

There seem to be a number of different reasons for the jerkiness, and therefore a number of different solutions have been suggested in various posts by various people.

I too have the latest drivers. Apparently getting the latest drivers also works for some with this issue. Didn't help me (different parade perhaps?). -framerate-23 is one that works for me, and may also work for some others. I did a fair bit of experimenting before settling on the rate of 23 fps for my setup. framerate=30 isn't effective for me either. Peoples mileage may differ, so I suggest a little trial and error with the rate !

Phil

JCitron
December 22nd, 2009, 05:14 AM
no rain here!

There seem to be a number of different reasons for the jerkiness, and therefore a number of different solutions have been suggested in various posts by various people.

I too have the latest drivers. Apparently getting the latest drivers also works for some with this issue. Didn't help me (different parade perhaps?). -framerate-23 is one that works for me, and may also work for some others. I did a fair bit of experimenting before settling on the rate of 23 fps for my setup. framerate=30 isn't effective for me either. Peoples mileage may differ, so I suggest a little trial and error with the rate !

Phil

This shows how many variables as their are PC rigs out there. What may work for one doesn't work for another. For me it was going to Open/GL from DriectX. I didn't even bother with the framerate settings.

There are more things to this than just the video settings. What I think is happening is we've discovered away to slow down the program's video framrerate to compensate for other bottlenecks within the system. In some cases it's the overall throughput of the system buss, or perhaps memory speed, and or the system cache, or perhaps the hard drive that the program is loaded on.

John

Dermmy
December 22nd, 2009, 07:23 AM
framerate-23 is one that works for me, and may also work for some others. I did a fair bit of experimenting before settling on the rate of 23 fps for my setup. framerate=30 isn't effective for me either. Peoples mileage may differ, so I suggest a little trial and error with the rate !

Phil

Wow. I thought 23 fps / 30 fps - what the heck, try anything. -framerates=23 fixed it! I think I can spot the difference between 30 and 23, but not by much and I am willing to admit that the 'difference' might be imagination. Whatever - smooth 23fps is better than stuttery 30fps. Thanks Phil!

Andy ;)

Edit - also swapped back and forth between DX and GL. DX is definitely better, not by a lot, but better is better...

geoffwilliams
December 22nd, 2009, 09:46 AM
A couple of things I have noticed about TS2010.
It doesn't always work to keep the draw distance slider full left. Sometimes moving the slider to the right actually improves smoothness.

Remove your name and password from the options, for some reason, an internet connection auses lags and pauses.
Geoff

FootplatePhil
December 22nd, 2009, 12:46 PM
Wow. I thought 23 fps / 30 fps - what the heck, try anything. -framerates=23 fixed it! I think I can spot the difference between 30 and 23, but not by much and I am willing to admit that the 'difference' might be imagination. Whatever - smooth 23fps is better than stuttery 30fps. Thanks Phil!

Andy ;)

Edit - also swapped back and forth between DX and GL. DX is definitely better, not by a lot, but better is better...

:D

Phil

FootplatePhil
December 22nd, 2009, 12:58 PM
So here is a summary of the various things people have reported as helping with the jerkiness/lag issue in 2009/2010....

1. Get the latest video drivers

2. Swap from OpenGl to DirectX (or visa versa in a couple of cases !)

3. Remove UserName/Password from the options. Or as an alternative, deselect 'TS2009 iTrainz Chat Interface' in the Main Menu/Options/Global Interface Addons dialogue.

4. Add -framerate=23 to TrainzOptions.txt (which you will find in your C:\Program Files\Auran\TS2009 folder - use Notepad to edit). Experiment a little with the actual rate if you like.

Different things work for different people. Any others ?

Phil

Edit, as a BTW: My theory as to why 23fps works for me... I have a 75Hz refresh rate on my monitor. FRAPS shows that specifying -framerate=23 actually results in a framerate of 25 fps. I wonder if I was seeing a synchronisation problem. To check I tried setting -vsynch=1, but that no longer seems to work in 2009/2010 (FRAPS reported frame rates with -vsynch=1 were all over the place, and not factors of 75).

Dermmy
December 22nd, 2009, 01:57 PM
Edit, as a BTW: My theory as to why 23fps works for me... I have a 75Hz refresh rate on my monitor. FRAPS shows that specifying -framerate=23 actually results in a framerate of 25 fps. I wonder if I was seeing a synchronisation problem.

Don't think so! I use framerate=30 because I have a 60Hz monitor and thought 60/30=2, new frame every two cycles, gotta be good. But 23 still works better, although I haven't run FRAPS to see what I am actually getting. Of course the true fps without FRAPS running is probably higher than the reported framerate with FRAPS running....

Whatever - 23 works!

Andy :)

FootplatePhil
December 22nd, 2009, 02:07 PM
Don't think so! I use framerate=30 because I have a 60Hz monitor and thought 60/30=2, new frame every two cycles, gotta be good. But 23 still works better, although I haven't run FRAPS to see what I am actually getting. Of course the true fps without FRAPS running is probably higher than the reported framerate with FRAPS running....

Whatever - 23 works!

Andy :)

Oh well, it was a nice theory :hehe:

-framerate=23 fps may have another positive side affect - your video card will probably run cooler (mine does). That can't hurt !

Phil

Dermmy
December 22nd, 2009, 03:39 PM
I checked that one too - the whole box is cooler :)

Fraps reports a range between 20 - 25 ish, but 23 would be a fair average....