PDA

View Full Version : Imperial Hotel Errors



gooseman99
September 26th, 2009, 03:16 PM
I'm going through all my addons and making sure everything is right. Imperial Hotel <kuid2:63290:28019:1> has 2 errors. Warning: Tag 'icon0' in the container 'industry' is obsolete.
Warning: 'USA' is not a valid value for tag 'category-region'. This tag is now empty and a new value must be selected.
Does anyone know how to fix these? Sorry i'm still a newb trying to learn

pware
September 26th, 2009, 04:34 PM
Both are common problems and, fortunately, easily fixed or even safely ignored - neither should stop the asset from appearing.

To fix the problems: (some of these steps you have probably already done but I find it wise to always answer a problem by going back to square one for the benefit of others)

1. Open Content Manager (for Trainz 2006 and 2009)
2. Select the asset
3. Open Content Creator Plus (press Ctrl+Shift+C) - you may get a warning message about it being "created for an older version" - click OK.
4. In the "category-region" section scroll down the list until you find the empty check box "US" then click it - you can click any country it does not really matter. Since the tag is now empty, Trainz is just complaining about the empty tag. The problem was caused by the original creator entering "USA" in the configure.txt file instead of "US".
5. You may see an item called "icon0" on the main screen content control area (or it may be inside a folder called "Industry" - on the left of the screen. in which case open the folder to view its contents). The "icon0" item will have a big "X" graphic symbol next to it. Click the "X" to delete the item.
6. Save your changes (Ctrl+S) and then exit.
7. Commit your changed asset in CMP (select the asset and press Ctrl+M).

Hope this helps

gooseman99
September 27th, 2009, 10:53 AM
thank you very much. that fixed it. i've only been playing this game for a few weeks so i still have alot to learn.