PDA

View Full Version : Toughie Question: Blender and Trainz Problem



Len12
August 5th, 2009, 07:41 PM
I'm creating a train station in Blender. I created the objects which you see on the main body externally and imported them in to Blender on the main part of my station.. When I finished texturing them all looks great in Blender (brown background). However, when exported to Trainz you can see one of the objects is crooked. I'm baffled by this as what you see in Blender is what I'd like it to be but I can't figure out why in Trainz it's crooked. Any help would be appreciated.

http://i249.photobucket.com/albums/gg208/lenny12/Trainz2.jpg

http://i249.photobucket.com/albums/gg208/lenny12/Trainz1.jpg

johnwhelan
August 5th, 2009, 07:48 PM
When you import things from one CAD program to another they don't always get the same characteristics as you might like.

It looks a fairly simple shape have you tried just creating them in Blender?

Thanks John

Len12
August 6th, 2009, 09:55 AM
Yeah I actually redid the objects in Blender but am having material/texture errors. Back to the drawing board.

Jananton
August 7th, 2009, 10:20 AM
Hmm, the only thing I can think of is that the size and object rotation isn't normalised when you exported the station. If you still have the file that had this behaviour do a ctrl-a on each mesh and select the first option in the popup window "Scale and Rotation to ObjData". Now export again and see if this helped.

Greetings from hazy Amsterdam,

Jan

Len12
August 8th, 2009, 09:35 AM
Jan

Thanks for that. I'll give that a try. I still have the original file although I started a new one with the objects made in blender.