PDA

View Full Version : Juggled trackmarks



whyfly
July 25th, 2009, 08:08 PM
This one that has me baffled. Maybe it happens to you.

Let’s say I save three “Drive Via” trackmarks under the name “TripOne” for use in Copy Commands in Driver. In Driver, say I select two individual trackmarks to run a train, place TripOne after those, then add two other trackmarks after TripOne.

Here’s what it looks like (“t” is a trackmark): t1 t2 TripOne t6 t7

The train runs until the system gets to TripOne Then it seems to skip the three trackmarks inside the TripOne group, and runs t6 and t7. It also places the TripOne trackmarks at the end of the entire sequence, as seen at the bottom of the Trainz Driver screen (assume the used trackmarks stay visible).

Here’s what TRS06 runs: t1 t2 t6 t7 TripOne

Anyone know why that happens and how to get them to operate in the sequence I select?)


Art
(whyfly

R701Rusty
July 25th, 2009, 10:23 PM
Hi Art,
If it is possible why not try a "Wait For" command between t2 and Trip one with maybe a minute sitting there, giving the computer's system time to catch up? Other than that I cannot think of any reason at all right now that would cause this problem. Good luck!

Cheers
Russell.

whyfly
July 26th, 2009, 10:15 AM
Good idea, Russell. I'll give that a try. Thanks.

Art

Euphod
July 26th, 2009, 10:32 AM
I'm a bit unsure of what you mean, and am thinking that each Trackmark must have an individual name for them to work properly. Are you saying you have three marks, each named "Trip One". If so, I don't think that will get the job done.

whyfly
July 26th, 2009, 02:30 PM
Hi Euphod,

Each of the trackmarks within "TripOne" has its own name.

I think Russell was on the right track (no pun intended). When I run just a few trains, as each one executes t2 (see "Here's what it looks like" in my original post), TripOne expands to show all the trackmarks it contains, and they run in the correct order.

I'm increasing the number of trains I run at one time, and I suspect that above a certain number the "Juggled trackmarks" problem will occur again. I had been running more at one time, and that's when the problem occurs.

I'm using a 7-year-old computer with a 1.7 GHz processor, so when Russell suggested placing a "Wait For" command in front of TripOne so the computer can catch up, it made sense to me. If you saw how long it takes to load Surveyor and Driver on that computer, I'm sure you would agree that what he said makes sense.

Thanks for your reply.

Art