PDA

View Full Version : Does anyone know how to fix this?



Iced8383
January 1st, 2009, 10:23 PM
I've been getting errors like these in Trainz Objectz:

#### ERROR: ###### Wrong type - KIND = Nd "lever ####

Does anyone know how to fix this?

yungmoneyonpoint
January 2nd, 2009, 01:36 AM
hello iced ,
you have helped me so now i shall help you


::: This error has come from the installation or files

you need to reinstall trs 06



antwain

Iced8383
January 2nd, 2009, 01:47 AM
I'm using Trainz 04 for the locomotives. The error has come with a few of the locos from West Coast Trains.

yungmoneyonpoint
January 2nd, 2009, 01:50 AM
then they must have pirated locomotives :D

then try:

Reinstalling the locomotives

Iced8383
January 2nd, 2009, 02:04 AM
I'll try that out.

john259
January 2nd, 2009, 02:46 AM
Some assets are wrongly categorised as kind "nd" by Trainz Objectz due to a minor bug in TO. There's nothing wrong with TRS2004 or the asset and reinstalling either won't change anything.

The problem is caused by Trainz Objectz taking the first "kind" tag it finds in a config.txt file, even if it is inside another tag.

The asset does not need to be fixed in order to be fully operative in TRS2004, but if it is desired to solve the problem in Trainz Objectz then in the asset's config.txt file move the real "kind" tag to near the start of the file, perhaps just below the kuid tag. Be careful not to corrupt the first line of the config.txt file. Then shut down and restart Trainz Objectz to check that the spurious "nd" category has disappeared.

If you're not confident editing config.txt files, or if you don't understand their tags and curly brackets structure, then I suggest that the good old principle of "if it ain't broke don't fix it" applies.

HTH, John

Iced8383
January 4th, 2009, 09:12 PM
Some assets are wrongly categorised as kind "nd" by Trainz Objectz due to a minor bug in TO. There's nothing wrong with TRS2004 or the asset and reinstalling either won't change anything.

The problem is caused by Trainz Objectz taking the first "kind" tag it finds in a config.txt file, even if it is inside another tag.

The asset does not need to be fixed in order to be fully operative in TRS2004, but if it is desired to solve the problem in Trainz Objectz then in the asset's config.txt file move the real "kind" tag to near the start of the file, perhaps just below the kuid tag. Be careful not to corrupt the first line of the config.txt file. Then shut down and restart Trainz Objectz to check that the spurious "nd" category has disappeared.

If you're not confident editing config.txt files, or if you don't understand their tags and curly brackets structure, then I suggest that the good old principle of "if it ain't broke don't fix it" applies.

HTH, John

I don't exactly get it. Could you PM me by any chance?

john259
January 5th, 2009, 02:17 AM
If you don't get it then leave things as they are, it won't cause any problems in Trainz.

John