PDA

View Full Version : Question about site security.



DARTrider
May 30th, 2021, 04:06 PM
Hello!
I was going to purchase some locomotives from your main site (rrmods.us), but when I saw the "This page is insecure" warning I thought about it and decided to contact you guys about it. Is there any reason why this is like that, and should I be worried about someone taking my information? Please don't take offense. Thank you!

metrocentral
May 30th, 2021, 08:50 PM
^
HI DARTrider

It's been a while since I seen "This page is insecure" type page on various sites. What web browser/anti virus combination are you using?.
I stopped using Explorer and Mozilla web browsers ages ago and started using Oprea and Brave Browser which are more efficent at stopping tracking cookies, ads etc.
With regards RRMods along with the Adamovic and Guido73 Store I have had no problems with purchases of their locomotives and rolling stock over the years using PayPal.
You made need to set up a different account with each store ,needing a different password/ username etc, but I would say go for it because the quality of the locomotives and roling stock is first class.
Hope this helps you.

Cheers

Adamovic
May 30th, 2021, 09:33 PM
Hello, yes its 100% safe. We will investigate why this happened to you. Our payments are processed through Paypal and not on the website. If this error continues please email us at info@rrmods.us

DARTrider
May 31st, 2021, 06:14 PM
Gotcha, thanks!

Forester1
May 31st, 2021, 10:18 PM
The browsers have bumped up the level of TLS and other security protocols that they use, as well as generally requiring HTTPS instead of HTTP. If the site does not use all of the new protocols they are programmed to say it is an insecure site as a warning. The site is no more insecure than it ever was, but it may not have HTTPS or may not have the newer levels of protocols in place, so it may be less secure than sites that have updated.

OddRails
June 3rd, 2021, 10:36 PM
I did a search and loaded the site. It does not seem to be using HTTPS in the web address, so as you say, the browser is complaining that is using HTTP instead. My website, which has nothing of value on it, also hasn't been upgraded to HTTPS and my browser always complains about it being insecure.