PDA

View Full Version : Download Station asset (kuid number) has been locally modified error when uploading



janathan
May 21st, 2021, 09:23 PM
When trying to upload a content package to the Trainz store, I get the following two errors:
https://tccp.auran.com/content_creators/images/error_red.png <kuid2:140046:100104:1> : Download Station asset <kuid2:140046:100104:1> has been locally modified
https://tccp.auran.com/content_creators/images/error_red.png <kuid:140046:102271> : Download Station asset <kuid:140046:102271> has been locally modified

I'm not sure why these errors come up because the kuids in question are a horn and enginesound I put on the DLS and they don't appear as "modified" in content manager, rather they are listed as "installed from download station." Because of these errors, the build keeps failing. How can I fix this?

Christopher824
May 22nd, 2021, 03:52 AM
I checked both kuids in the Content Manager and they are not listed there for me. I do see them in the DLS online, but they must show in the CM to work, or the build machine will complain. Why its not showing in the CM is weird, as TS12 3.5 and up should work fine.

stagecoach
May 22nd, 2021, 06:03 AM
<kuid2:140046:100104:1> Amtrak AEM-7 Horn Shows in my CM for 100491 version of TRS19. Suggest you delete those and redownload them from the DLS. You may have the assets installed, and updated them to upload to the DLS at some point. But did you download them from the DLS? as CM may see the ones you have as modified and not as ones downloaded.

Christopher824
May 22nd, 2021, 06:35 AM
Very strange, they now show as available in the CM.

janathan
May 22nd, 2021, 06:37 AM
I tried deleting and re-downloading them three times, but I'm still getting these errors.

hiawathamr
May 22nd, 2021, 10:32 AM
Yeah since those KUIDs are on the DLS, you'll want to delete them and redownload them.
Since you tried it 3 times now, I would delete them again, run a database update (extended) and then download them.

If that still fails, then you got two choices:
- create a whole new content folder and just import all non-DLS items to that content folder your item, or;
- if its your item, just make it the next KUID newer so it obsoletes the previous version and Trainz will take the new item.

Cheers

janathan
May 22nd, 2021, 12:47 PM
I deleted them, ran an extended database repair, then re-downloaded them, but I'm still getting this error.

janathan
May 22nd, 2021, 08:58 PM
Update: I finally managed to fix the problem. What I did was delete the .tzarc file, then used content manager to re-upload the locomotives. It seems as though the tracksound was causing the problem, not the enginesound or horn, even though it specifically mentioned the horn. After deleting and re-downloading the tracksound, it worked. It now said, "Build complete."

pogger
May 25th, 2021, 01:20 PM
does anyone have <kuid:43955:54005> <kuid:39730:60003> <kuid:39730:60002> <kuid:39730:60000 for dls 0-6-0

Christopher824
May 25th, 2021, 06:20 PM
does anyone have <kuid:43955:54005> <kuid:39730:60003> <kuid:39730:60002> <kuid:39730:60000 for dls 0-6-0


Check here https://www.protrainz.com/index.php

pogger
May 25th, 2021, 06:28 PM
thank you Christopher824

pogger
May 25th, 2021, 06:36 PM
wait what do i do from there

Christopher824
May 25th, 2021, 06:48 PM
I believe it's a payware site, so you might have to sign up to get any info, or post your question in the General Trainz section of the forum for better answers. This section is for N3V TCCP developers and beta testers.