PDA

View Full Version : Black Friday Sale now live?



Forester1
November 27th, 2019, 12:22 AM
Got the Black Friday Email. Clicking on the Save Now button does nothing for me. I have tried copying the link and get nothing in the clip board. My mail seems to think there is a link there, but neither Open link nor Copy link works. Tried viewing the source and can't find any links beyond the store.

Tried going to the Trainz Portal, to the store, no sign of a sale. Well, it's 10pm here in Idaho and I have to get up and drive through a snow storm tomorrow to where I will not have internet for the duration. Too bad. It would have been glorious.

Tony_Hilliam
November 27th, 2019, 12:43 AM
Most strange. The link works here, and there are many signs of the sale here at. store.trainzportal.com

Perhaps try Ctrl-F5 to refresh the cache.

euromodeller
November 27th, 2019, 04:12 AM
Same here using Thunderbird Client, all other links work, BF link doesn't!

There is a large Banner in the Trainz Store so that works :)

clam1952
November 27th, 2019, 07:22 AM
Just use this https://store.trainzportal.com/

Link is dead in Thunderbird, open in browser allows you to click the main BF link which then gives you


You have chosen to open:
Store.trainzportal.com
which is: Binary File (0 bytes)
from: https://mailchi.mp
Would you like to save this file?

With a save file or Cancel button.


Needs a proper link in the email.

hiawathamr
November 27th, 2019, 11:46 AM
I use Outlook (the client program installed on the computer) and Firefox, and when clicking on the pic, it has taken me to the store where the sale is happening - no problems.

epa
November 27th, 2019, 12:05 PM
I use the default Windows 10 Mail, and the default Mail apps on MacOS and iOS. I can confirm that all links work fine on all three clients.

Matt

robd
November 27th, 2019, 03:23 PM
I note that a 365 day 1st class ticket now costs a whopping US$34.69, and with the so called 'Black Friday Discount' of 25% it is now US$26.04. The last 1st class ticket I bought, in June this year, cost me US$27.99 as I recall, so no great saving at all!! I can't even use my Trainz Pointz ( I have 1475 that seemingly appeared from nowhere ) as the purchase price is less than US$29.00!

I sometimes wonder whether I actually need a 1st class ticket anyway but it's now a right rip off!

Rob.

RPearson
November 27th, 2019, 04:08 PM
... I can't even use my Trainz Pointz ( I have 1475 that seemingly appeared from nowhere ) as the purchase price is less than US$29.00! Rob.That minimum purchase price is if you redeem them all. I think you can redeem a lesser amount - like 500 points gets you a 5 USD discount on purchase price of 19 USD or more. But check it out under all rewards on the pointz panel.

I've got about a week left on my current 365day ticket. I have 2 still sitting there not activated. I bought them a couple years ago - on sale for 20 USD or or a bit less IIRC.

Bob Pearson

nexusdj
November 27th, 2019, 04:43 PM
My DLS Ticket ran out the other day , Glad I waited , Just purchased a 1 year ticket for just over $21 (17.02) that included the sale discount plus the extra $5 off with 500 points . Gained quite a few points back from the purchase .

Vern
November 28th, 2019, 12:51 PM
About the true worth, did the same move here - just a shame I cashed up the $10 voucher before spotting there was a $29 minimum spend. Valid for 12 months so can always use it to pre-buy next years FCT a bit early.

The GBP also seems to have rallied a bit against the US$, probably temporary until whatever disaster awaits the outcome of Dec 12, so another reason to get in now. Oh and my previous FCT expiring just as I was about to download some rather large in file size PBR textures probably played a pivotal part, too. No silver or gold subscription required... :cool:

valbridge
November 28th, 2019, 06:25 PM
My annual FCT ran out a couple days ago and looking at download speed without it is a ridiculous 9.5 kbs [on average]. The annual price without any 25% discount is, in my opinion, a high price to pay. I also though the purchase of TRS19 UK edition gave me a FCT but I do not seem to have it. Quite a price hike from 12 months ago. I've said before on the forum $US to $AUD is unfavourable to Australian users.