PDA

View Full Version : Missing Tile Errors when importing a 97271 session into 96000



pware
October 14th, 2018, 07:36 AM
I have one computer with TRS19 build 96000 and another with TRS19 build 97271.

I have been working on a large route and session using TANE SP3 HF1 and have been importing the route and session into TRS19 build 96000 without any problems. I would then tweak the environment setting in the session and save it as a new session in build 4.6 (TRS19) format. The upgraded session file worked on both TRS19 96000 builds. This process continued after I upgraded build 96000 to 97271 on one of the computers. The modified build 4.6 session created on build 96000 loaded and worked perfectly on build 97271.

I then tried the reverse approach. I imported the TANE route and session into TRS19 build 97271 without any problems and it worked perfectly. I then tweaked the environment settings as before and transferred the route and session into TRS19 build 96000. The route imported perfectly but the session threw up a list of "VE180 Integrity check failure on mapfile_index.obs (and .rlr, .trk and .vtx). One or more route/session tiles may be missing"

I thought that it may have been a problem with the route and session I was working with so I created a very simple one baseboard layout and a session and tried again. Same result. In both cases, the faulty session is shown with the red warning icon in the Surveyor/Driver selection screen.

Checking the imported test TRS19 route and session in the 96000 Surveyor it was missing the baseboard and all its contents. Checking the imported full TRS19 route and session in the 96000 surveyor nothing appeared to be missing but some of the Enhanced Interlocking towers had lost their set paths.

I have reported this as a bug and have supplied a screenshot of the CM error messages and the .cdp files.

So are build 97271 sessions incompatible with build 96000 installations?

JCitron
October 14th, 2018, 08:47 AM
I wouldn't think this would work due to the new build number. At this point, the build number 4.6 maybe going through some iterations until the developers flush out issues and the program progresses towards release. These changes maybe subtle and internal in some cases while others maybe obvious such as the missing tile issue you have. This maybe due to an internal file format change that the older build doesn't recognize.

Going from an earlier build to the current works fine, or going from T:ANE to the current build works fine because the older data-format is handled internally, but as soon as the files are saved, they are now at the newer version.

pware
October 14th, 2018, 04:14 PM
Thanks for that suggestion. I thought that it might be a possibility since it also occurred on the simple baseboard test route and session. I will revert back to my original practice of TRS19 tweaking on the earlier version.

pware
October 15th, 2018, 04:56 PM
You were on the money John. I got a response from QA that builds are not backward compatible.

JCitron
October 15th, 2018, 05:34 PM
You were on the money John. I got a response from QA that builds are not backward compatible.


Thank you for letting me know.

This "smelled" a lot like some IT stuff I've run into with some SQL ODBC drivers. In that case it was the only driver I could download was slightly newer than the one supported by the program. The version numbers were the same, however, something was different inside. At that time, I should have been suspicious because my downloaded version was a tiny bit bigger than the one I had already downloaded but couldn't use because that version was corrupt. It was as though the cards were set against me all around.