PDA

View Full Version : Approach Medium routes installing incorrectly



stevie10188
September 23rd, 2018, 02:32 PM
I'm sure most of you reading this have heard about Approach Medium's new Pennsylvania & Berwind route. Well, I installed the route, sessions, session dependencies, and the payware extension the "extra" pack and I still get unknown and faulty dependencies. The same thing happens with T:ANE. Any help will be appreciated, thanks.

MTH_ELECTRIC_TRAINS
September 23rd, 2018, 02:37 PM
He might have used ones he didn't know were not on JR's site. I can't help you much more than that but you could contact JR or him for more help. I don't know how many people have his route and I can't get it because I don't have T:ANE. The missing ones could be from other dependencies needed on JR. There are more than just his content pack you know. Like JR's buildings, etc. His content pack ONLY CONTAINS locomotives and rolling stock, nothing else is included in it and all other assets are DLS or JR's.

JCitron
September 23rd, 2018, 02:50 PM
Check the Real-squash bogey. This introduces a bug, which needs to be repaired. I have reported this already, but the fix is easy to do. If you have this bug, it will cause faulty rolling-stock.

If you are missing assets, ensure you also installed the buildings and scenery items. The links for this stuff is located on the route page just below the screen shot thumbnails.

Once installed check your open for edit items. If there are any, and I'm sure there will be, highlight them all and revert to original.

After doing this, the route is error free in my TRS2019 install.

stevie10188
September 23rd, 2018, 02:56 PM
Thanks, guys. I'll try both and let you know how it goes.

stevie10188
September 23rd, 2018, 04:44 PM
I got it to work in T:ANE (Can't remember how...) and I exported the dependencies as one file, and I tried importing it into TRS19 CM, but it keeps saying "Unable to open CDP file '_' for reading". And after I exported the files, the T:ANE assets became faulty.

JCitron
September 23rd, 2018, 04:47 PM
I got it to work in T:ANE (Can't remember how...) and I exported the dependencies as one file, and I tried importing it into TRS19 CM, but it keeps saying "Unable to open CDP file '_' for reading". And after I exported the files, the T:ANE assets became faulty.

Click on the faulty assets in T:ANE and try revert to original.

The CDP file sounds corrupt, or it's too large - being too large is more likely the problem. Try to keep the CDPs below 1GB. 512MB is safe all around.

stevie10188
September 23rd, 2018, 10:58 PM
Pretty late, I know, but I reinstalled my dependencies pack (It was able to read because I split it into 10 different files...), and now 79 assets are faulty. Never ends.

JCitron
September 23rd, 2018, 11:22 PM
Pretty late, I know, but I reinstalled my dependencies pack (It was able to read because I split it into 10 different files...), and now 79 assets are faulty. Never ends.

But what are the faulty assets - maybe you should post this over in the Jointed Rail forum? Without knowing what the exact errors are, it's kinda hard to help you there. It's like saying Ouch, but not saying what really hurts. :)

I installed this route in TRS2019 without any errors as I said. The freight car issue may or may not be related.

Rigid-Articulation
September 24th, 2018, 04:16 AM
where do you get these routes?

grazlash
September 24th, 2018, 04:46 AM
Jointed Rail - the route is free but the content pack with sessions and rolling stock costs $$$
cheers
Graeme

Heinrich505
September 24th, 2018, 09:00 AM
Stevie10188,
I initially had about 58-62 missing assets in each of the sessions after I downloaded to TANE. The rolling stock file was huge and took a long time to load and install. I thought it was hung up. Then I noticed in-game that rolling stock was showing up on map view, but they were invisible in regular view.

I was going to send JR a message about this, but then tried re-installing just the rolling stock file. Again, it took a long time but the second time must have worked. The invisible rolling stock then became visible in game and I could couple engines to them. JCitron might have the right angle on the rolling stock problem. It took so long to re-install the rolling stock file but the faults and the missing assets all went away.

I intended to try and load it to TRS2019, but after the struggle I had getting things right in TANE, I think I had better leave well enough alone...for now. :confused:

You might try re-installing just the rolling stock file. Hope that helps.

Gary

stevie10188
September 24th, 2018, 12:01 PM
But what are the faulty assets - maybe you should post this over in the Jointed Rail forum? Without knowing what the exact errors are, it's kinda hard to help you there. It's like saying Ouch, but not saying what really hurts. :)

I installed this route in TRS2019 without any errors as I said. The freight car issue may or may not be related.

All of the faulty assets have the error VE65(The texture.txt file is missing for texture resource '_')

JCitron
September 24th, 2018, 03:10 PM
All of the faulty assets have the error VE65(The texture.txt file is missing for texture resource '_')

Try this:

In Content Manager right-click on the a faulty asset.

Click on Open Config.txt file for editing. - Notepad should open up.

Look for a line that has __ in it.
Delete that line completely. This means highlighting from left all the way across it. Remember to keep the formatting the same though for other lines. This is important.

Look for others and delete those.

Save the config.txt file.
Right-click on faulty asset and choose Submit.

The faulty asset should disappear from the faulty assets list. If it remains, repeat the above steps and check your work.

If this works, repeat the process for others that are faulty.

Why you have these beats me. It could be I fixed these ages ago, therefore, I don't have them anymore. With nearly 200k assets installed, it's difficult remembering which ones in particular I've repaired.

MTH_ELECTRIC_TRAINS
September 24th, 2018, 09:17 PM
What I don't understand is why the authors or publishers of the crap don't fix it already. I know some things that are super old off the DLS that are faulty from the get go but seriously, brand new stuff? C'mon, JR is better than that! Also, try installing anything in TS12, it just plain sucks. I don't even know why I tried to get like 300 new assets today, it never goes well.

mrjunction
September 25th, 2018, 09:50 PM
Jointed Rail - the route is free but the content pack with sessions and rolling stock costs $$$
cheers
Graeme

I did not D/L this route,however this is reminiscent of the Tide Water route, and the issues I had with it. I'm beating a dead horse here,but the "free" D/L routes lately have been incomplete,and the only way to finish them is to buy the matching content pack.

MTH_ELECTRIC_TRAINS
September 26th, 2018, 07:45 AM
Well, Approach Medium's pack only includes locomotives, rolling stock and I don't even know if it includes the sessions or not. It does NOT include buildings, track or anything like that so I don't understand why it isn't working. Remember to get the TRC Crossing system stuff too! He used that on his route and NOT ATLS. Also, there are buttons on the route's website page and they are dependencies needed. They are "buildings" and "scenery". Remember to download them if you haven't already but you probably have. To get the TRC V3 system go here: https://sites.google.com/site/trcv2english/. There are files that are only gotten through that website which are the common files need to run the system.

acbdfaqoz
September 26th, 2018, 12:17 PM
Hi.

All assets needed to install the P&B into TANE are on the same JR download page. That includes all JR buildings, scenery, rolling stock and their dependencies (except what's on the DLS). I've taken the time myself to ensure all dependencies are indeed included by installing the route and dependency packs (including the payware) into a fresh TANE installation. If any of the dependencies are open for edit you'll have a problem, so make sure everything has been installed and submitted. Whatever isn't JR content can be obtained from the DLS. You'll probably want a FCT to do this. I've had absolutely no problems with this installation.

The P&B was built in TANE and as of right now is only supported in TANE. I briefly tested the P&B in TRS19 during my live stream a few weeks ago and found I was missing about 100 assets that were built-in content in TANE. I've been hearing some people have had success installing the route in TRS19 but personally I don't recommend it since the route uses billboard trees and grasses that look pretty awful in 19 -not to mention the missing or faulty assets that you'll likely encounter. My advice is either to wait until I can update the route to TRS19 or you'll have to figure it out on your own.

-------------------

Further details:

Freeware route includes:
The route
JR buildings (non-DLS route dependencies)
JR Scenery (non-DLS route dependencies)

^Fully operational on it's own. You won't need to download anything from any 3rd party sites. Payware add-on not require.

Payware Add-on Includes:
8 P&B loco's
P&B Hoppers
P&B Caboose
4 Sessions using JR rolling stock
All dependencies for the payware pack

-Joe

stevie10188
September 26th, 2018, 10:16 PM
You're probably right, Joe. I even installed one of my ustom routes and everything went to faulty. I'll stick with TANE until TRS19 actually releases. Hopefully it'll be fixed and the P&B will be updated to TRS19 standards. However, my route has TRS19 dependencies, so I'll have to do tons of work like re-ballasting and replacing the track and the environment settings. Until then, thanks for the help, guys and have a good day!
...or night. depends on where you are or what time you're reading this.