PDA

View Full Version : Missing Dependencies.... but there isn't any missing!



Davie_UCF
August 27th, 2018, 09:30 PM
Yoho,

Imported all my content from TANE, it submitted while I was at work. Everything seems fine, except a few hundred assets showing red with missing dependencies.
I click 'List Dependencies' and I get all the dependencies, with nothing missing/unknown or available to download.
So no missing assets really?!

I've tried a database rebuild twice and still.
Semi-solved this... potentially a bug?
In the example pictured, I deleted 'Recycled Paper (Bail)' and re-downloaded it (as it was on the DLS), this removed the 'Modified' status and then the asset worked fine.

It seems the asset being modified was the issue?


http://i68.tinypic.com/2vkdawl.jpg

JCitron
August 27th, 2018, 09:53 PM
I downloaded, right-clicked and picked download and a whole lot of commodities came in and fixed mine. For those that didn't go away, opening for edit, on the modifed assets, and the reverting to original seemed to fix that issue. I now have 13 sessions missing a single asset, which I'm now waiting for.

I pointed my TRS19 to a backup copy of my T:ANE database, ran an EDR overnight and had a good lot of stuff in there. There were 1700 or so faulty assets. 1600 were repaired by opening in bunches and running PEV's Images2TGA on them. The remaining were a mix of a few errors, false errors, and missing assets related to Payware not ready yet.

Would I do this in the future? Probably not. I think when all is done being fiddled with and the version is official, I'll cut with the past and start with fresh content, my purchased content will of course be transferred over along with routes and sessions I want to keep. The 14 years, going on 15 years of Trainzing, creating a very, very large cumbersome database of old stuff, making clean-up difficult.

ZecMurphy
August 27th, 2018, 11:35 PM
Hi Davie_UCF
It's possible that the database hadn't fully updated. In this case, I'd suggest running a database repair first by clicking on 'developer' on the top toolbar, then click on 'rebuild database'. If this doesn't resolve the issue, then please try running an extended database repair by clicking on 'developer' on the top toolbar, then hold the CTRL key and left click on 'rebuild database' and see if this resolves the issue.