PDA

View Full Version : Problem with Importing TANE Content to TRS2019



Heinrich505
August 27th, 2018, 07:34 PM
I've just come from the Wiki page that gave instructions for importing data from TANE to TRS2019. I was unsuccessful.

During the Christmas sale for N3V I purchased several engines from their DLC page, all from JR. They all downloaded properly into TANE.

For the past several days I have been trying to move some of them from my TANE content into my TRS2019 content...unsuccessfully.

I tried to bring over the PRR SD9 Two Pack, but both ended up with Missing Dependencies that had no address, or were just Faulty. I thought it might be because it was a two-pack.

Today I tried to import a single engine purchase: <kuid2:661281:100031:1> Wilamette & Pacific SD7 #1501

1. The original payware engine is located on my old computer, so I went into content manager for TANE, then clicked on Export to CDP, it converted to a CDP file, and I sent it to an external hard drive.

2. I connected the external hard drive to my new computer.

3. In the content manager of my TRS2019, I clicked on File>Import Content Files, located the proper CDP on the external drive, and clicked on Open.

4. I received a message that the content was downloaded into TRS2019 with no errors or warnings.

5. Everything should be okay, right? Nope.

In the content manager of TRS2019, I can find the engine, listed as <kuid2:661281:100031:1> Wilamette & Pacific SD7 #1501. It shows as modified payware. In my TANE content manager it shows as Installed/Payware.

In game, the engine can't be found. I tried finding it in the search section, but it wasn't there. I tried going into a route and editing the route, pulling up the engine choices. It isn't there.

I have already checked for Open for Edit, and also Faulty in the TRS2019 Content Manager. Nothing is open for edit and the engine does not show as faulty. I also tried dragging the CDP file from the external drive into TRS2019 Content Manager, but it wouldn't let me.

Maybe I am missing something. I'm open to suggestions. :confused: I'm hoping I am not going to have to re-purchase them for TRS2019.

Heinrich505

JCitron
August 27th, 2018, 08:05 PM
Hi Gary,

If this is N3V Payware, you can't bring it in and you need to download it from the DLC servers. Not all content is ready yet and will be made available as it goes through QC and testing before it's uploaded.

For the stuff directly from Jointed Rail, you can bring it over. You may have to go back and grab the missing dependencies separately - It helps to view dependencies of the asset before exporting to ensure you get all the parts. For those assets that have some components built-in, in T:ANE, they shouldn't be imported over, though using PEV's Images2TGA will fix those, and you may have to go back and get them separately. This method, however, is not recommended, and N3V will make the T:ANE content available in TRS2019 as soon as all the packages are QC'd and uploaded.

For other stuff, yes, there will be some errors though they're easy to repair using PEV's Images2TGA, and Note Pad or some other error. For some assets, the error in the config.txt file refers to a number which should be a whole number (integer) rather than a floating number. For these, simple remove the decimal value plus the decimal point, save and close the Config.txt file and you should be good to go.

Using the method above, I was able to bring over all my Jointed Rail content without too many problems.

Heinrich505
August 27th, 2018, 08:28 PM
John,
Thanks for the reply. It is payware, purchased from the N3V store, but once my card was approved, I was directed to download it from a different location, because it was JR stuff, so it doesn't show in My TRAINZ as downloadable content. I did the download into TANE and there were no problems.

But, trying to move it over won't work. Very odd. I thought maybe it was because of the size, so I even zipped it to the removable hard drive, then unzipped it when I attached it to my new computer.

Once again, I had no errors or warnings, nothing open for edit, nothing listed as faulty, and the engine shows in the TRS2019 Content Manager. Apparently there is nothing to fix and all is well. But, it isn't showing in the game, anywhere.

I haven't tried bringing over any other JR stuff, other than my abortive effort with the purchased JR PRR GP9 2-pack. That one did show with faulty and missing dependencies. Ugh. Kind of frustrating.

Heinrich505

JCitron
August 27th, 2018, 08:40 PM
John,
Thanks for the reply. It is payware, purchased from the N3V store, but once my card was approved, I was directed to download it from a different location, because it was JR stuff, so it doesn't show in My TRAINZ as downloadable content. I did the download into TANE and there were no problems.

But, trying to move it over won't work. Very odd. I thought maybe it was because of the size, so I even zipped it to the removable hard drive, then unzipped it when I attached it to my new computer.

Once again, I had no errors or warnings, nothing open for edit, nothing listed as faulty, and the engine shows in the TRS2019 Content Manager. Apparently there is nothing to fix and all is well. But, it isn't showing in the game, anywhere.

I haven't tried bringing over any other JR stuff, other than my abortive effort with the purchased JR PRR GP9 2-pack. That one did show with faulty and missing dependencies. Ugh. Kind of frustrating.

Heinrich505

No errors in Content Manager, Gary?

I modified my Faulty filter so I now have three of them. Filter No. 1 is the Faulty catch-all, Filter No. 2 is Missing Dependencies only, and Filter No. 3 is Faulty only no missing or faulty dependencies.

Using Filter No. 2 I was able to track down the missing stuff, and using Filter No. 3 I was able to find out what was broken. I'm now down to 13 sessions, which are missing an asset or two and a handful of trainz, which also rely on payware linked assets.

Once you find out who is what and where, you can fix the problem.

ZecMurphy
August 27th, 2018, 11:40 PM
Hi All
Just to confirm, assets that show the status as 'payware' in content manager (along with assets that show the status as 'built-in') cannot be manually transferred to TRS2019.

We will be making the TANE compatible DLC packs available for TRS2019 throughout the Early Access period, and we anticipate that all will be available in time for the Official Release. However we cannot say when any specific DLC packs will become available.

You can find more info on transferring content from TANE to TRS2019 on the following page of our Help wiki: http://online.ts2009.com/mediaWiki/index.php/Help:Importing_Content

Regards

Heinrich505
August 28th, 2018, 09:49 AM
Zec,
Thanks for the information. If I’m reading this right, by DLC packs you mean both purchased routes and purchased engines, correct? Glad to know this is being worked on. :)

Heinrich505

Lewiscc65
August 28th, 2018, 01:02 PM
I brought over a route & session of mine from Tane to 2019 and the session lost half of the commands in the schedule library. It also changed all the driver assignments.