PDA

View Full Version : Faulty Asset Wooden Platform Low kuid:9:28001>



Heinrich505
May 12th, 2018, 11:39 AM
I've been running into this asset for several routes. It seems to show up in quite a few places. Right now I have this as a faulty asset in ConrailNJT, Indiana Western, WINTER-INDIANA WESTERN-2010, Krashnburne RRCo, and PortSwitchingCo 1a.

The asset shows as Installed from DLS, Faulty Dependency. The error message shows:

- <kuid:9:28001> VE65: The *.texture.txt file is missing for texture resource 'platform.texture'.
- <kuid:9:28001> VE65: The *.texture.txt file is missing for texture resource 'platform_wooden_spline_end/platform.texture'.
- <kuid:9:28001> VE65: The *.texture.txt file is missing for texture resource 'platform_wooden_spline_start/platform.texture'.

When I hit dependencies, I get:

<kuid:-25:1062> TANE 1Trk Wood
This is not in red, so this appears to be okay. But the asset won't work because of the listed errors.

Being rather new to all this, I'm open to suggestions. As this asset seems to show up frequently, it would be great to have it fixed. Just not sure how.

Thanks,

Heinrich505

Max_Trax
May 12th, 2018, 12:13 PM
Had the same problem with this asset. Deleted it and removed its kuid from the route.

Content Manager does show a non-spline version as built-in but I don't know if it can replace the faulty one. kuid2:9:28000:1 Platform Wooden Low

normhart
May 12th, 2018, 12:20 PM
That is odd, it is installed in my 90945 and is error free. Checked texture and both the platform.texture.txt and platform.tga file were in there.

shaneturner12
May 12th, 2018, 12:32 PM
I'd suggest trying a revert to original on it as it sounds like a built-in item.

Shane

Heinrich505
May 12th, 2018, 02:41 PM
Shaneturner12,
Tried the revert to original - no go. Still shows faulty.

It was also faulty in my 90945 build and I'm running 93467 now.

MF01
May 12th, 2018, 02:44 PM
Did you do like this ?: Open for modification then revert to original ?

Heinrich505
May 12th, 2018, 03:55 PM
MF01,
Yes, like that. Open for Editing, Revert to Original. It still shows as Installed from DLS,Faulty. Ugh.

I also have that other version, <kuid2:9:28000:1> Platform Wooden Low. That seems to be okay.

Heinrich505

MF01
May 12th, 2018, 04:00 PM
With kuid2 and the :1 at the end it means that it’s a new version so cool that it works now

Heinrich505
May 12th, 2018, 04:27 PM
So it's okay to delete the faulty one?

MF01
May 12th, 2018, 05:01 PM
Yep go on but it has to be obsolete

JCitron
May 12th, 2018, 05:17 PM
Any assets that have a very low Kuid such as 9 or 1, or a minus Kuid such as -1, -25, -10, etc. are built-in or Auran assets from earlier versions of Trainz. If you see a 523 asset, this are also built-in or N3V assets, or sometimes Auran assets as well.

If you happen to import one of these built-in assets from TS12 or before, or you've gotten them off the web somewhere that they have been uploaded and shouldn't have been because these are now on the DLS except for TS12 ones, you can repair them using a utility.

You need to open the asset for edit, and run PEV's Images 2 TGA (Images2TGA) program. Open up the .texture file one at a time, and save as to extract the image from the .texture file. Once you've completed that process, you can then submit the asset and the problem is resolved.

Heinrich505
May 12th, 2018, 07:27 PM
JCitron,
Sent you a PM.

Heinrich505

JCitron
May 12th, 2018, 11:00 PM
JCitron,
Sent you a PM.

Heinrich505

PM responded too. I hope I explained the stuff. :)