PDA

View Full Version : Track has appered and will not delete



rawhide60
March 27th, 2017, 05:16 PM
Hi Can anyone help me please. I am using Trainz 12 What has happened random track has appeared. I am using concrete track and the track that has appeared is the wood. I've done database repair and still have the track which will not delete any help would be most appreciated.

cascaderailroad
March 27th, 2017, 05:42 PM
Usually you can slide it out of the way, and shortening it, by connecting track, or FT Track to it ... it probably has morphed into some thing unusable

ministerfarrigut
March 27th, 2017, 05:44 PM
I've run into problems like this in Trainz 2010 where a random track spline jumps out of nowhere. The only way I was able to fix it was to exit out of Surveyor completely. It sucked but it deleted that spline if I didn't save it.

mikeaust
March 27th, 2017, 08:24 PM
I have found that sometimes a piece of industry track becomes detached from an industry when it is deleted and stays on the route somewhere. You can remove it by using the industry button and delete.
Cheers,
Mike

JCitron
March 27th, 2017, 10:11 PM
It could be layers too.

What you might have done is did a bit of editing in the Route editor and then placed track again in the Session editor on the route layer because you didn't see the track you placed in the first place. Now you've gone back to the route editor and there are tracks there you can't move. Try editing the session and merging layers into the Route layer and see if that helps.

It could also be that there is a consist sitting somewhere on the track. If there's a consist on the track you can't delete the track until you remove the consist first.

rawhide60
April 5th, 2017, 05:39 PM
Hi Everyone many thanks for all your help. I've tried all but to no avail. It's back to the drawing board and start again.

SailorDan
April 5th, 2017, 06:04 PM
Hi Everyone many thanks for all your help. I've tried all but to no avail. It's back to the drawing board and start again.

Are your sure it's a spline and not fixed track with attachment points?

Try attaching other splines to it. Sometimes it deletes itself as soon as you make the attempt. But if it works, at least you know what type of object you should be trying to delete.

Vern
April 6th, 2017, 10:56 AM
Which version of TS12 are you running? If it's anything other than the last one sounds like you may have fallen victim to the infamous spline detach and frozen bug. Try inserting a spline point along the affected section and see if that allows you to delete the offending section(s).