PDA

View Full Version : Faulty SRS Trainz Locomotives



Steprei01
November 13th, 2016, 07:03 PM
So, I just downloaded 3 locomotives from SRS Trainz. They are the UP SD70M with letters, the UP SD60M (Triclops), and BNSF SD60M (Triclops). Unfortunately, they were all faulty after I downloaded them. :(

The two SD60M Triclops locomotives were both faulty. The UP SD70M was fine, except that the lettered paint skins were faulty.

epa
November 13th, 2016, 07:23 PM
So, I just downloaded 3 locomotives from SRS Trainz. They are the UP SD70M with letters, the UP SD60M (Triclops), and BNSF SD60M (Triclops). Unfortunately, they were all faulty after I downloaded them. :(

The two SD60M Triclops locomotives were both faulty. The UP SD70M was fine, except that the lettered paint skins were faulty.

What kind of errors are they showing? Right click on the faulty items in Content Manager and click "View Errors".

Matt

Steprei01
November 13th, 2016, 08:12 PM
What kind of errors are they showing? Right click on the faulty items in Content Manager and click "View Errors".

Matt

The BNSF Patched and UP SD60M locomotives' image file are incorrectly used as both texture.txt source file and raw image file.

The UP SD70M Letter Painted Skins however says that main1-01, main2-01, main1-02, main2-02, main1-03, and main2-03 are all each incorrectly used as texture.txt source files and raw image files.

epa
November 13th, 2016, 09:22 PM
The BNSF Patched and UP SD60M locomotives' image file are incorrectly used as both texture.txt source file and raw image file.

The UP SD70M Letter Painted Skins however says that main1-01, main2-01, main1-02, main2-02, main1-03, and main2-03 are all each incorrectly used as texture.txt source files and raw image files.

Have you tried re-downloading and reinstalling the locomotives?

Matt

lego207
November 13th, 2016, 09:35 PM
If you go into the config file for the Faulty assets and replace '.tga' on the file with an error (main1-01.tga, for example) with '.texture' your errors should be fixed quickly. The BNSF Patched and UP SD60Ms errors refer to their thumbnails and the UP SD70M Skins refer to all the skin files. Just replace .tga with .texture on all of them and submit edits and you should be good to go.

Cheers,
SM

H222
November 13th, 2016, 11:00 PM
Probably would've made the most sense to post in srs's thread, where he'll see this and respond to you himself.

http://forums.auran.com/trainz/showthread.php?134157-SRS-Trainz-SP-SD70M-locomotives-released

Steprei01
November 13th, 2016, 11:37 PM
If you go into the config file for the Faulty assets and replace '.tga' on the file with an error (main1-01.tga, for example) with '.texture' your errors should be fixed quickly. The BNSF Patched and UP SD60Ms errors refer to their thumbnails and the UP SD70M Skins refer to all the skin files. Just replace .tga with .texture on all of them and submit edits and you should be good to go.

Cheers,
SM

I changed the '.tga' with .'texture', but that only made things worse. I got more errors saying:

- The tag '0' in 'textures' must have an image file extension.
- The tag 'main2-02.texture' in container 'textures' is empty.
- The tag 'main2-02.texture' in 'textures' must have an image file extension.
- The tag '4' in 'textures' must have an image file extension.
- The tag 'main2-03.texture' in container 'textures' is empty.
- The tag 'main2-03.texture' in 'textures' must have an image file extension.

Steprei01
November 13th, 2016, 11:45 PM
NVM It's been fixed. Thank you. ;)

But now it's faulty just the the two SD60Ms. :/

Steprei01
November 15th, 2016, 11:11 PM
All three locomotives have the same issue for being faulty. I don't know how to fix this. :confused:

Example:
- Image file 'up_sd70m_images/sd70m_icon.tga' is incorrectly used as both a texture.txt source file and a raw image file.

BuilderBob
November 16th, 2016, 12:24 AM
All three locomotives have the same issue for being faulty. I don't know how to fix this. :confused:

Example:
- Image file 'up_sd70m_images/sd70m_icon.tga' is incorrectly used as both a texture.txt source file and a raw image file.

The reason for the error message and the fix (depending on the exact cause) are all available here:
https://en.wikibooks.org/wiki/Trainz/AM%26C/Fixing_Assets#Error:_Image_file_.27.3Cimage_filena me.3E.27_is_incorrectly_used_as_both_a_texture.txt _source_file_and_a_raw_image_file.

You need to look at the particular condition of the asset and the various texture and image files, and not just follow a rote procedure.

Billythekid01
December 28th, 2016, 12:28 AM
Yesterday I downloaded the srstrainz bnsf sd60m triclops all the assets worked except this one. Error: Required tag 'full-throttle-speed' was missing and has been set to default. It has killed the sd60m engine and caused the locomotive to not load, I posted about it in the srstrainz sd60m thread in freeware announcements but I got no reply so I came here

Dcatrambone
January 16th, 2017, 08:41 PM
I Use PM2IM To fix PM Meshes and stuff :/ I Think it will work for the errors Just dont know or something :confused:

torino72
January 16th, 2017, 11:54 PM
Yesterday I downloaded the srstrainz bnsf sd60m triclops all the assets worked except this one. Error: Required tag 'full-throttle-speed' was missing and has been set to default. It has killed the sd60m engine and caused the locomotive to not load, I posted about it in the srstrainz sd60m thread in freeware announcements but I got no reply so I came here


Since you have not registered your version of Trainz I'm assuming you are using TANE since versions below TANE do not produce this error (TS12 & below). The trainz-version number at which these locos was created does not produce errors for the absence of the entry "full-throtle-speed". The engine spec used for the SD60M's was not an SRS creation so he cannot fix it. It is a trainz-build 2.9 asset (9000:51021) by author "weevil".

But, you can fix it yourself in either of the following ways.

1. Bring the two SRS SD60M's up in Surveyor and right mouse click on one of them and select "View Dependencies". A list of dependencies will appear. Next, click on "View in Main List" and a "editable" list of the dependencies will appear. The one named T3P SD60 TRS v1.1 is the engine spec causing your error. In your case, my advice is to replace it using either of the two methods listed below.

Method 1 (Harder but something you need to learn): Clone the T3P SD60 TRS v1.1. This creates a new version under your kuid ID. The cloned version will be "Open for Edit". Right click on the cloned version, select "Edit" and then select "Edit in Explorer". This gives you access to the config.txt file. Click on the config.txt file and it will open as a text file. Scan down the file until you reach the tag "Motor". The last entry in "Motor" will be "air-drag-coefficient 0.0032". Enter the following two lines below that last entry and maintain the indentation & spacing of the last entry:

throttle-notches 8
full-throttle-speed 31.2928

Save you changes and commit the cloned asset. The final step will be to open the locomotive(s) for Edit and Edit in Explorer (as you did the engine spec file) and find the config file entry for "enginespec". Change the kuid number of the engine spec to your new kuid number of the cloned engine spec you just created. Save & commit and I think that will cure the error so you can use the loco.

Method 2 (Easiest): Go to the DLS and download asset SD60 Engine, kuid2:45324:660:4 by norfolksouthern37. It already has the needed entries. Simply substitute the SD60 Engine kuid number for the enginespec of the SD60M, config file (as above), save & commit and the error should be gone.