PDA

View Full Version : Bdneal chop nose SD9 error



qazwaseat
September 1st, 2016, 05:14 PM
Hey all! I've recently downloaded Bdneal's chop nose SD9 for a reskin project. After downloading the asset, this appeared: Error: Unable to load source texture 'hash-d9\copytempsrc1xy2195l35\sd16_body\light1.convert-tex' in subst 'local'. I don't think that i'm the first one to have this issue, so if anyone knows a fix to this if you could please help.

Cheers, Qaz

shaneturner12
September 1st, 2016, 05:18 PM
Is that the error you get if you right-click the asset and use View Errors?

Shane

qazwaseat
September 1st, 2016, 05:22 PM
I found this when i first installed it. Here are what I found in View Errors.

-Error: Unable to load image file 'light1.tga' for texture 'sd16_body\light1.texture.txt' while validating mesh 'sd16_body\sd16_body.lm'
-Error: Unable to load primary texture 'sd16_body/light1.tga' for texture file 'sd16_body/light1.texture.txt'.
-Error: Binary conversion failed for texture resource 'sd16_body/light1.texture.txt'.

Cheers, Qaz

BuilderBob
September 1st, 2016, 05:55 PM
-Error: Unable to load image file 'light1.tga' for texture 'sd16_body\light1.texture.txt' while validating mesh 'sd16_body\sd16_body.lm'
-Error: Unable to load primary texture 'sd16_body/light1.tga' for texture file 'sd16_body/light1.texture.txt'.
-Error: Binary conversion failed for texture resource 'sd16_body/light1.texture.txt'.

Firstly, delete it in CM and download it again, to be confident it isn't a download error.

If that fails to clear the error, look here:
https://en.wikibooks.org/wiki/Trainz/AM%26C/Fixing_Assets
under the specific error message. It is a problem with a textute.txt file and/or an image file. You should be able to look through the different causes of these errors and identify which one applies to this asset.

qazwaseat
September 2nd, 2016, 12:56 PM
Thank for the help guys. Turns out that the problem was a duplicate light1.texture file that wasn't routing it to the sub-folder.

Cheers, Qaz

JCitron
September 2nd, 2016, 01:39 PM
Thank for the help guys. Turns out that the problem was a duplicate light1.texture file that wasn't routing it to the sub-folder.

Cheers, Qaz

I'm glad you figured it out. This is a very common problem with older assets and it will get better once the content repair group, now reorganized, goes through and updates the content on the Download Station.

There are some tool which will definitely help you with other errors you'll run into.

- PEV Software:
Images2TGA
PM2IM
Quick Shadows

- Other tools:
Notepad (built into Windows)
A photo editor - Paint.net, GIMP and similar.

You can get the PEV Tools from Shane Turner's link on his signature - he hosts them on his website.

These are definitely more than valuable for repairing content.