PDA

View Full Version : I need a little help!



trainzlover2010
May 20th, 2016, 03:28 PM
This is my third post lemme know if i am doing something wrong:)
So the link for the Amtrak Phase IVb Amfleets from AmericanTrainz is not working.
I was wondering how I can get them!

Thanks!

jjanmarine3
May 20th, 2016, 11:55 PM
yep...your'e doing something wrong.

GoofusClam57
May 24th, 2016, 04:23 PM
The link provided at http://www.amtraktrainz.com/stock.html resolves to http://www.amtraktrainz.com/downloads/RS/Amtrak%20Amfleet%20IVb.cdp.cdp, which, as you have noted, does not work.

Try this link instead:
http://amtraktrainz.com/downloads/RS/Updates/Amtrak%20Amfleet%20IVb.cdp

I found if at http://s4.zetaboards.com/amtkz/pages/rs_dl/