PDA

View Full Version : BW9 Cab Mechanism Error



BigBoyFan4006
March 19th, 2016, 05:48 PM
The T:ANE CM says that the cab mechanism for the BW9 (the JRPX Club Car version) is faulty. After clicking "View Errors and Warnings", this is the error: "VE73 : Image file 'glass.tga' is incorrectly used as both a texture.txt source file and a raw image file." How should I go about fixing this?

HPL
March 19th, 2016, 05:53 PM
This is due to the faulty IOTM that modifies it (and reverting to original doesn't work).

BigBoyFan4006
March 19th, 2016, 06:04 PM
So is there anything I can do to fix it?

HPL
March 19th, 2016, 06:26 PM
If you have a backup, yes!

BigBoyFan4006
March 19th, 2016, 08:06 PM
I was able fix the problem by replacing the thumbnail in the config file, though I left the original thumbnail within the asset just in case.

BigBoyFan4006
March 19th, 2016, 09:05 PM
And now the BW9 itself is faulty, even though it wasn't before. Apparently the T:ANE CM isn't liking the tag "size" being used as an integer value for the diesel and sand products. I've deleted and reinstalled the asset at least half a dozen times, and it's still faulty. So I tried changing "size" to "value", and the error that popped up was that "value" was not a permitted tag, and that the required tag "size" was missing. I changed the tag back to "size", and became faulty again.

norfolksouthern37
March 19th, 2016, 09:25 PM
the tag "size" being used as an integer value for the diesel and sand products.

actually its saying it needs to be an integer value and not a float as it was entered in. for some odd reason they think it is justified to make this an error rather than just convert the value as they must have been doing for years. yeah okay some people use too many decimal places but so what tuncate them.

anyway, it means instead of something like 1234.567 it needs to be 1235 - should be simple enough.

if anything says its using a texture as source and raw image it means that it cant be used from the config as a .tga bt also referenced by the object as a .texture. this usually means making a new thumbnail for it.

idk why the BW9 would have any of these problems but ill get someone on it.

BigBoyFan4006
March 19th, 2016, 10:02 PM
actually its saying it needs to be an integer value and not a float as it was entered in. for some odd reason they think it is justified to make this an error rather than just convert the value as they must have been doing for years. yeah okay some people use too many decimal places but so what tuncate them.

anyway, it means instead of something like 1234.567 it needs to be 1235 - should be simple enough.

if anything says its using a texture as source and raw image it means that it cant be used from the config as a .tga bt also referenced by the object as a .texture. this usually means making a new thumbnail for it.

idk why the BW9 would have any of these problems but ill get someone on it.

Alright, thanks for the reply.

HPL
March 20th, 2016, 07:53 AM
anyway, it means instead of something like 1234.567 it needs to be 1235 - should be simple enough.

That's what I tried, it fixed the asset, but no way, "BW9 Cab Mechanism" stays as faulty and consequently all stuff using it becomes unusable. I submitted a ticket to JR's support.

HPL
March 20th, 2016, 08:29 AM
Found a way to fix the problem: correct the faulty tags in the Config file of the loco, then submit all "open for edit" EXCEPT "BW9 Cab Mechanism": choose "Revert Unsubmitted Edits" for it. Then everything's OK!

jointedrail
March 20th, 2016, 08:52 AM
That's what I tried, it fixed the asset, but no way, "BW9 Cab Mechanism" stays as faulty and consequently all stuff using it becomes unusable. I submitted a ticket to JR's support.

The good copy of BW9 cab mechanism also resides in the cab dependencies area of our website if you are having issues with just that specifically.

Alco_P-A
March 20th, 2016, 10:10 AM
Installed this loco and it says JRPX locomotive leasing #92 Modified,Faulty. When I look in the list dependencies it shows 10 open for edit. Should I submit edits or what? Thanks.

HPL
March 20th, 2016, 10:13 AM
Read 2 posts above...

Alco_P-A
March 20th, 2016, 10:57 AM
should be an easier way than messing with files.

HPL
March 20th, 2016, 11:40 AM
Yes: reading post #7 in thread IOM February.

jointedrail
March 21st, 2016, 07:59 PM
Any issues with faulties or warnings have been addressed. If you have them, delete the current item, redownload and reinstall.