PDA

View Full Version : Unable to link comiled script class



ctclark1
March 5th, 2016, 03:03 PM
TS12 - I'm not sure what action might have caused it (I did move my trainz installation to a new SSD recently, including all content) but even after reinstalling (overwriting) all signal-related assets with new downloads from the JR site, including the Signal Library and Detail Kit, all of my JR "05" type signals are listed as faulty with "Unable to link compiled script class" in CM, the TADDaemon shows "TrainzBaseSpec::GetGSClass> Could not load Trainz library jrs_signal.gsl for" each KUID involved. Again, this only affects the 05 types, of all styles - Safetran Clight, Safetran NS, Searchlight, and GStyle Trilight.

As I said, I redownloaded all the signal content from the JR site just now, and forced it to overwrite in CM, and ran an EDR. No luck. Any ideas??

Dinorius_Redundicus
March 5th, 2016, 04:45 PM
"Sometimes the error is fixed by deleting everything in <TrainzInstallation>\UserData\cache\libraries, and committing the asset again."

I got that quote from a 1 minute search of the Forum on the keywords "compiled script". There were a few others such as "re-install the JR scripts library". You should do your own search and see what comes up.

ctclark1
March 5th, 2016, 06:01 PM
You should do your own search and see what comes up.
For the record, I did about 20 minutes of searching on google (which typically does a better job of searching the forums than the forum search) and came up pretty empty handed, so pardon me if I didn't search exactly the correct words.

Also, I'll point out that I mentioned in my first post that I did "re-install the JR scripts library"...

Dinorius_Redundicus
March 5th, 2016, 08:56 PM
You're welcome.