PDA

View Full Version : Missing Session Again



railsong
February 28th, 2016, 04:48 PM
Well this is the second time the session I was working on for several weeks has disappeared again. The last time this happened I could load the AutoSave file and go ahead and update it for what I lost. This time there is no AutoSave file listed. I am about ready to give up on TANE. Really discouraging. When I try to load the session for my route I get the Error that my session won't load. It is listed as faulty in CM. I tried to Revert to Original, but that didn't help. I don't know what to do. Sorry to bother you folks again, but I really would like to know what is going on. Any suggestions will be appreciated. I am running TANE SP1 Build 80349. Thanks....:(

pware
February 28th, 2016, 06:44 PM
One suggestion that seems to resolve faulty asset errors in TANE that are not actually faulty has been to start TANE but DO NOT click the Manage Content or Start Trainz links. Instead, go to the Developer menu on the launcher and select Rebuild Database.

Without knowing what you have been doing with your session, a common cause of the problems you have been experiencing (and this has been going on in Trainz versions since they introduced sessions) has been creators editing the route instead of the session. When you start Trainz (any recent version) to edit a route for which you have already created at least one session, the trick is to select the route, then view the sessions, then select and edit the session - even if all you want to do is add a single tree to the route.

Hope this helps.

Roy3b3
February 28th, 2016, 06:48 PM
I had similar problems like that some time ago (and it wasn't T:ANE) I also run Build 80349.
I found how to maintain both Route files and Session files. Every time I start a new route I make sure at the closure of my editing to first save my route file, then immediately go into Driver mode and place a consist on the track, then I exit. It asks whether I want to save the 'Default' Session file or not. I always say 'yes' and close the game.
Then anytime and for whatever reason, I can open either the Route file or the Default Session file.
I've found that the 'Auto-Save' usually saves the Route and not the Session, so I make it a point if I want to create a 'lasting' Session to come back to occasionally, I'll specifically name that Session differently so it is easily identifiable. I then make sure that when exiting that Session, I don't overwrite it. If I 'do' make some changes in the Session 'edit' then I'll add a 'v.001' tag to it. I can then choose what files to keep or delete.
Good luck, cheers,
Roy3b3

railsong
February 28th, 2016, 08:06 PM
Thanks pware. I did the Rebuild Database thing, but it didn't change anything. Still can't load the session I have been working on. I always choose the route and then choose the session I am working on and then the Edit Session choice. I never edit the Route at all. I don't know why this has to be so complicated. I think I will just give up on T:ANE. It's not worth spending all those hours building and then losing it all... Roy3b3, that sounds confusing to me. I have been playing with Trainz for years and never had this much trouble. Sure hate to give up on it but like I say just don't know what to do...