PDA

View Full Version : Red Bug errors on Portal emit



jbaxter1964
December 17th, 2015, 07:19 PM
I'm seeing the following errors on JR rolling stock when emitting from a portal in TANE. Tried reinstalling the latest FX files and the general fixes for TANE but no change. Any ideas or suggestions to fix is greatly appreciated!!

JRTraincar : Asset.LookupKUIDTable> unable to find 'red' in kuid-table (file asset.gs)

<kuid:506034:345751> "BN 60Ft.9In. Woodchip Car"

Stack dump:

function $Asset@Asset::FindAsset(string), line -1
function $void@FX_Traincar::carMon(), line 448

FX_Caboose : GameObject::Sniff> Target object is null) (file gs.gs)

<kuid:175455:100196> "SP C50-9 Police Caboose"

Stack dump:

function $void@GameObject::Sniff(GameObject,string,string,b ool), line -1
function $void@FX_Caboose::Init(), line 216
function $void@MeshObject::Init(Asset), line 316

norfolksouthern37
December 18th, 2015, 03:15 PM
for the first one it appears that the red corona is not present in the item's kuid table


for the second one i do not know. do you have the latest tfx library?

nawlins
December 18th, 2015, 03:44 PM
I've been seeing the second one on many pieces of rolling stock, no just JR stuff.

Haven't a clue as to the cause.

Cheers

shaneturner12
December 18th, 2015, 03:46 PM
Might be worth keeping an eye out when the second one happens if any trains have shown up at the bottom as derailed.

Shane

jbaxter1964
December 18th, 2015, 04:12 PM
Thanks for the replies! I have been trying various approaches with Asset X but no luck so far. The interim solution has been to replace them with assets that work without error.

jbaxter1964
December 18th, 2015, 04:15 PM
for the first one it appears that the red corona is not present in the item's kuid table


for the second one i do not know. do you have the latest tfx library?


NS,
I will try adding the kuid on the first. I am using 1.33a for FX, so I believe I'm current.

norfolksouthern37
December 18th, 2015, 04:41 PM
I dont have an explanation for the caboose problem. I can see that it is failing to start a message sniff on the train and that is null for some reason. it might mean the portal is not done making the train or it might mean something totally different. The real confusion for me is if any one JR item had this problem though they all would as they use a common code base in TFX. The caboose this was reskinned from was released in TS12 and has been around since 2010 and never has displayed these issues that I know of. Even if the train derailed it should become another train entity, that much was accounted for in the code.

jbaxter1964
December 18th, 2015, 05:17 PM
Exactly! I'm using the TS12 SP caboose (the source for the police caboose reskin) and it comes out of the portal with no errors. Probably 90-95% of all my rolling stock is JR and these are the only issues I'm currently having.