View Full Version : No Property Editor for trackside objects HF2

November 7th, 2015, 06:12 PM
The Property Editor opens up blank in T:ANE HF2 with any of my scripted signals. <kuid2:481384:11110098:2> is an example. This has been confirmed by two other users.

The property interface pretty much follows the wiki on PropertyObjects to the letter. It calls a minibrowser, nothing fancy. The signal scripts have been tested and work and are error- and warning-free in TS2009 through TS12SP1. They show no errors even when installed into T:ANE and versioned at 4.2.

November 8th, 2015, 12:30 PM
Just an update, no fix yet. I have my HTML wrapped in HTML tags (and tried using BODY tags too). It turns out GetDescriptionHTML() isn't even being called when accessing the Property Editor. GetProperties() isn't being called either.

November 9th, 2015, 10:09 PM
Fixed but with possible new bug:

Thanks to trev999 for the fix and for noticing the new issue. So, it turns out that the cause of the property editor not displaying anything was due to my not enclosing the HTML in html and body tags. So, I tried editing my scripts in T:ANE' Content Manager. No luck. Even putting a simple string in would not cause anything to display. I tried setting breakpoints in GetDescriptionHTML, but it didn't appear these were even being called.

So Trevor pms me today noting that he was able to modify my scripts in TS12 and import them into T:ANE getting the property editor to open successfully displaying the options for edit. He noticed that he wasn't able to edit the scripts directly in T:ANE'S CM, hence why he added the tags in TS12 and exported the fixed script to tane. Based on this, it would appear tane never recompiled any of my adjustments; hence why none of my modifications while in tane were taking effect.

In any case, it would seem the "bug" that was the topic of this thread has been resolved or worked-around, but a new one may be have been uncovered (assuming it hasn't been reported already.)

This thread may be closed.