PDA

View Full Version : internal test build 79091



WindWalkr
October 23rd, 2015, 05:06 AM
Hi all,

A new internal test build is available. Changes include:

* Fixed a case where meshes were loaded twice during validation. This will suppress certain duplicate messages and slightly reduce the time taken for validation.
* Improved the ability to detect when parent meshes have draw distance limits set, to automatically cull the child meshes.
* Improve the UX of the Driver "Message Window" to reduce confusion over its intended use.
* Fixed some assorted crash bugs that were present in the previous test build.
* Added software rigid animation support to the mesh loader, to resolve a case where the result differed from TS12 when animated meshes were being supplied without animations applied.
* Improved the handling of LOD distance validation wrt/ draw distance limits.
* Changed how mouse hit-detection works in the 3D world. This should hopefully not result in any user-visible outcomes.
* Re-enable the OpenGL renderer option as a beta consideration. Please note that this does not mean OpenGL compatibility will be any better off than where it was when we removed the option; functionality and performance are still dependant on your GPU driver.
* Modified how content lists are redrawn when scrolling in the Windows native GUI. This should give a smoother scrolling experience while the list is being refreshed.
* The outer shadow PSSM split now extends to the full draw distance.
* Improved the responsiveness of Surveyor while the asset lists are being refreshed.
* (Hopefully) improved compatibility for pre-v4.0 scripts which rely on precise positioning from MeshObject.SetMeshAnimationFrame().
* Numerous Interlocking Towers fixes.

kind regards,

chris

pcas1986
October 23rd, 2015, 05:47 AM
The second item interests me but I'm having difficulty figuring out how to test it. I'd appreciate some thoughts on this, if not from you, then perhaps Andi or someone else smarter than I. :o

andi06
October 23rd, 2015, 12:16 PM
If I understand correctly this should reduce or eliminate false positives during validation of LOD, the issue described in this thread (http://forums.auran.com/trainz/showthread.php?123653-Bogie-LOD-Problems) has now been fixed for instance.

The easiest way to test may be to find assets that were producing the 500 poly error in previous builds where you didn't agree with the numbers that validation was producing and to check them again in the new build.


* Changed how mouse hit-detection works
I have one or two assets which rely on detecting mouse-over events. These still work as expected.
Have you changed the mouse messages?
I'm not seeing messages in the log output. This isn't a problem most of the time but it can be useful to see them on occasion - have we lost this facility altogether?


* Numerous Interlocking Towers fixes.
I still can't find the interlocking tower asset <kuid:401543:3220>

pcas1986
October 23rd, 2015, 02:19 PM
....

The easiest way to test may be to find assets that were producing the 500 poly error in previous builds where you didn't agree with the numbers that validation was producing and to check them again in the new build.
....

Thanks. One of my other locos on the "to be fixed" shelf will fit into that category.

ianwoodmore
October 23rd, 2015, 04:39 PM
Instal

Painless.

Direct X

Initial tests seems stable.

Open GL (beta)

Tried on three different installs C:\ SSD micro; E:\SSD Mini and F:\HD maxi

Micro is TANE Std builtins.
Mini is TANE Deluxe builtins.
Maxi is TANE Std, plus Total DLS with significant number of assets repaired.

WIN10 werfault (TANE stops wkg) occurred at 2min 15 after selecting session. Tried both KS County Trees for Life and several other builtins in micro and mini instals.
No difference on Vsync none, full or half.

On maxi I don't get werfault but while I have sound and zoom, screen is black in all camera modes except map view.
Map view shows overlays text, track and consists. Consists are moving and can be selected. But no terrain showing.
Surveyor much the same. No terrain or objects only text and Pick Lists.

I also tried legacy session with same results.

In CM on maxi; normal operation. I can also go to Surveyor, Driver and Preview, but same as above.

%CPU and Commit Memory were higher than DirectX but not excessive.

whitepass
October 24th, 2015, 12:14 PM
OpenGL did not work, game would start normal but in Driver all I got was black with icons and menus, Map mode did work.
GTX 460 GPU

Save game not saving every thing and some Speedtrees have shadows that do not show leaves at some angles.

JCitron
October 24th, 2015, 01:33 PM
Open/GL causes Crash to Desktop (CTD) when launching driver.

GTX780Ti - NVidia Driver: 358.50
64 GB RAM
400 GB swap
4 x Hard drives: C: SSD 480GB, 3x 2TB Seagate 7200 Barracuda
Process Intel I7-5830 3.5Ghz
Windows 10

JCitron
October 24th, 2015, 02:22 PM
Switched to DirectX, clicked on a route.

The screen changed to Select Route but nothing appeared. I left it running because I had to help bro clean up something. I came back and there's still nothing but the same message. a check of the log shows this message here:

; File routesmenutwor.gs, Line 3444, ER_NullReference
; *** DUMPING ALL THREAD STACKS ***
; *** STACK DUMP OF THREAD 0 ON GAME OBJECT (null), id 57 ***
; function $void@Achievements::ThreadCountdownVariableSync(), line -1
;
; Stack Dump...
; function $void@RoutesMenuTWoR::TADRequestRefresh(), line -1

martinvk
October 24th, 2015, 03:07 PM
Opened the Interlocking Towers in OpenGL and was inside a coal mine. Pitch black except for the coupling target and the junction names. When I zoomed out far enough, the sun came out and i could see the tracks, etc.

In Kickstarter County, selected the Chinese Electric SS4 session in driver and found myself in the same mine.

Changed to DirectX and after a restart visited the same two routes / sessions. The sunshine was out in both cases

Current NVidia driver is 355.82 on a GTX 750. I think OpenGL still needs some work.

andi06
October 24th, 2015, 03:17 PM
Plus Point: The screen no longer goes dark when the Object Property window is selected - and about time too.

Minus Point: Its no longer possible to properly edit the driver setup list and similar commands via the Edit Session dialogue.

A little bird tells me that these two items are related, at least if you remove the semi-colon from line 7 of ...resources/dialogs/surveyor/properties.txt then the dark old days are restored but Edit Session works again.

pcas1986
October 24th, 2015, 03:23 PM
Negatives:

My OpenGL experiences are the same as Ian's and Whitepass. Basically, its unusable. Gigabyte GTX780Ti with latest drivers.

On opening one of my sessions, I got a bunch of script errors - see below. The session still seemed to run OK.

http://i1188.photobucket.com/albums/z410/casper131/Ashampoo_Snap_2015.10.24_17h04m44s_001__zpssmkkodd w.jpg

Some trees look rather washed out and transparent. Other trees look great.

http://i1188.photobucket.com/albums/z410/casper131/Ashampoo_Snap_2015.10.24_17h12m35s_003__zpsnuw7zwg q.jpg

Frame rates are way down. I haven't been running sessions in test builds but I did try KS-Fossil Fuels and was only getting 22-25fps around the time the train encounters the kamikaze log loader. Normally I get around 55-60fps at that location. Performance was noticeably jerky in any session. Lowering the shadow quality made zero difference. Are the test builds de-tuned for performance?

Driver Message Window: I hadn't seen this before so I assume these are the messages at the lower left of the window? The font colour was a bit hard to see with my eyes and the messages didn't stay on screen very long.

Also spotted this problem with a level crossing in my route:

http://i1188.photobucket.com/albums/z410/casper131/Ashampoo_Snap_2015.10.24_17h14m45s_004__zpsnikbfrq c.jpg
The boom attachment points are offset in a couple of axes. I'm sure this was ok in a previous build.



On the plus side my CTDs from the previous build have gone.

I should be able to do some more testing on Monday and Tuesday.

whitepass
October 25th, 2015, 04:01 PM
Surveyor has no ground textures and if you have a train on some bridges the train cars on it will not show in a screenshot.

Fraps will not run on TANE under OpenGL.

WindWalkr
October 25th, 2015, 06:12 PM
Thanks guys.

Since some of you have been playing with OpenGL, please ensure that any comments which are specific to OpenGL are tagged to indicate such. Preferably try to avoid combining reports about OpenGL and general problem reports into the same post.

As always, if you're having trouble with a particular asset, please give the details of the asset and post onto a new thread.

kind regards,

chris