PDA

View Full Version : Who Is Building or Updating Traincars to TANE Standards?



andi06
October 8th, 2015, 05:30 AM
I've now been directly involved in updating or building five different traincar assets (three of my own and a couple where I've advised other users) to the sort of standard that N3V are expecting for TANE and I've formed my own views of the advantages and drawbacks of the process, given the available tools.

It would be very useful to know how other authors are finding the process (if you don't have write access to TrainzDev feel free to comment by PM) Please keep your comments general if possible, specific issues are already getting enough attention in this forum.

Its clear that N3V tend to take more notice of complaints (and of compliments) when there is a certain weight of numbers behind them and if any clear patterns emerge from this enquiry it will be easier to press for improvements.

whitepass
October 8th, 2015, 09:40 AM
I am trying but as there are no TANE standards to go by and some bugs yet to be fixed it's kind of hard.

andi06
October 8th, 2015, 10:13 AM
Perhaps we should define 'TANE standards' as meaning 'error-free in trainz-build 4.2'.

pcas1986
October 8th, 2015, 10:43 AM
As mentioned elsewhere, I'm trying to build my current steam loco project to TANE standards including the efficiency criteria within the Preview Asset tool. That's on hold while I'm on holiday. Once I finish this loco I intend to redo my other locos. There are two of those with variants of one. Those may get a different kuid as the build structure is likely to be very different.

I don't think I yet have a guide, for want of a better term, for all the aspects of traincar building in TANE. I do have some ideas but I need to get them down on paper.

VinnyBarb
October 8th, 2015, 05:17 PM
I have 3 RDCs (in my signature picture below) and a diesel electric locomotive and my created and yet to be upgraded Ghan and Indian Pacific coaches waiting to make TANE V 4.2 compliant, again, not TS12 but specific but for TANE V4.2 on compliant. I have yet to see what is all required for TANE to make these to work error free and others I indent to create. Please don't ask "what errors" as anyone else who created TS12 content and trying to make this V4.2 specific knows what errors one encounters in TANE. As said, I also reported these in the past but as it seems no notice is taken of reporting, why do it then?

Where are all the new tags, new features needed to make these working correctly, best to be found in one place (TANE specific)? Plus as said, not everything is fixed that was working faultless in TS12 but not in TANE, for me it is some nightmode, some autonumbering, some animation, specifically on simple 30 frames/sec fans on top of locomotives which go back and forth and do not rotate as they do so well in TS12.

Another issue I have is with normal mapping and specular being used on my TS12 created locomotives, where this looks exceptional well in TS12, yet in TANE you would think, what the hell is happening here and looking grotesque in TANE to say the least (somewhere posted here with pics by me in the forum a few months ago, as the search here is so lousy, I did not find the relevant pages). I had advise given to me to adjust the lighting in TANE to have my created locomotives looking reasonable, well hello, a user starting up a vanilla version of TANE and installing content is not likely to adjust lighting etc. just to give some assets a better look, as then other assets might/will look out of place.

I have TANE patched up to 76536, I am sick and tired to install patch after patch and not seeing my issues addressed at all, despite reporting these several times and have something broke, which was working before. No wonder one is losing interest as a CC, I guess, like some/many other CCs., it is really not very good saying by N3V, continue creating in TS12 and all will be well for TANE. Will it ever?

Guess what, in the meantime I am playing games I neglected to play over the years and I am finding it to be much better than to get upset about waiting and waiting and still waiting and all the other cr@p going with it, as:

first, some necessary information for creating for TANE is not existing,

second, it might be scattered all over the Wiki, including some important info which is now on cloud documents (why?) not every CC can access,

third, features working before in TS12 are still not working in TANE,

forth, it seems somehow going one step forward but two steps back with each new patch,

fifth, where are some of the tools needed by us CCs to make good content, N3V can not always pretend people like andy06, PEV and others will provide some of these. N3V develops TANE, they should know how TANE works (sometimes one wonders), they more than anyone else should provide these, after all, they get my (and other CCs) created content for free,

etc.

Now I usually only look in the developers forums, seeing hardly anything new posted and 10 minutes after I log out again. A sad state of affairs where we have now a "Trainz Content Creation Forum", a "Trainz Dev" forum and the always having been the all important "Content Creation Support" forum splitting our voices even more to be heard.

My opinion, for what it is worth

VinnyBarb

pcas1986
October 10th, 2015, 06:12 AM
On thinking about this more, and reading VinnyBarb's post, perhaps there are several categories of issues:

1. Getting traincars, and probably assets in general, working in 4.2 as they were in TS12. The latest build (78871) appears to address some of those issues. I rather think that would be a priority.
2. The guidance required to improve asset efficiency using the new tools. We, the TrainzDev community, should be able to provide that but it will take some time while we work it out for ourselves.
3. There are "odd" issues like the changes to materials that, while not actually an error, will annoy creators because they "don't look right" and mean new settings have to be determined. I've run into this problem.

whitepass
October 10th, 2015, 08:56 AM
Perhaps we should define 'TANE standards' as meaning 'error-free in trainz-build 4.2'.

So how do make a CDP if CM gives you an Error?