PDA

View Full Version : Another Validation bug



andi06
October 7th, 2015, 04:07 PM
I've just received this one on a trainz-build 4.2 traincar in build 78602:

- Indexed meshes are not supported for traincars as of trainz-build 3.8. It is recommended that you upgrade 'shadow.im' to a LOD mesh.

JCitron
October 7th, 2015, 04:15 PM
I've just received this one on a trainz-build 4.2 traincar in build 78602:

- Indexed meshes are not supported for traincars as of trainz-build 3.8. It is recommended that you upgrade 'shadow.im' to a LOD mesh.

Interesting. Why would we need a 'shadow.im' mesh? I thought these were all going away because of the built-in shadow capabilities.

WindWalkr
October 8th, 2015, 12:49 AM
As JCitron says, we don't have shadow meshes in T:ANE and so as far as the engine is concerned, "shadow.im" is just another mesh and must follow the same rules as any other traincar mesh, so the validation message is quite correct.

If that were on a pre-T:ANE asset, then it's reasonable to expect that it should be suppressed.

chris

andi06
October 8th, 2015, 04:45 AM
"shadow.im" is just another mesh and must follow the same rules as any other traincar mesh, so the validation message is quite correct.
Point taken, however the mesh container name 'shadow', which was used in this case, was formerly a 'reserved word'. Might it not reduce potential confusion to recognise this in the message?

WindWalkr
October 8th, 2015, 04:48 AM
Debatable. An explanation of this sounds like something which should go in the docs, not the error message. There are only so many characters we can fit on the screen.

chris

andi06
October 8th, 2015, 04:55 AM
Debatable. An explanation of this sounds like something which should go in the docs, not the error message.
One for the proposed direct link to a wiki page, fair enough.

At the moment its no big deal, you can just down-version the asset, but this sort of thing will come back with a vengeance when your end of support policy is extended such that 4.2 is the lowest trainz-build that the DLS will accept.