PDA

View Full Version : DLS Uploads ...



andi06
September 23rd, 2015, 08:42 AM
... are the source of a great deal of frustration.

The latest in a long series of problems is with this set of assets (http://forums.auran.com/trainz/showthread.php?123072-BR-27T-Iron-Ore-Tippler-Modular-Chassis-Library). A great deal of research and modelling effort has been put into making these as accurate, flexible and efficient as possible.

There are five assets involved, a bogie which also serves as a mesh asset for the wagon underframes and a set of four wagons each of which use the bogie and its underframe meshes.

All of these were uploaded at the same time but the author has received DLS rejections for all four of the wagons, its as yet unclear whether the bogie has been accepted.



Dear LNERlover5,
The addition of your content file BR_27T_Iron_Ore_Tippler_-_Standard_1.cdp has failed due to the following reasons:
<kuid2:430793:100211:1> : Required alias mesh asset <kuid:430793:100177> is missing and cannot be validated


The assets are trainz-build 3.7 and all of the mesh-asset and kuid-table entries refer to the correct bogie kuid.

I've seen this sort of thing before, often where cross-asset-includes or script libraries are involved and the frustration is compounded when the email rejection either seems to contradict the contents of the upload or fails to give enough information to fix the problem.

I'm afraid that the Helpdesk isn't usually particularly helpful in dealing with these issues.

WindWalkr
September 23rd, 2015, 09:31 AM
No, helpdesk isn't really set up to handle this sort of thing. Could you please get the creator to build a CDP of the assets in question and send them through to trainzdev@auran.com - or if they're too big to email, put them somewhere and send in a URL. I'll run them through the submission process and see what happens.

thanks,

chris

andi06
September 24th, 2015, 05:12 AM
I'm advised that this upload has now resolved itself. The perception is that the wagons were accepted once the bogie asset found its way into the system.

I'm not sure whether this is due to intervention by Chris or not.

WindWalkr
September 24th, 2015, 08:35 AM
No intervention on our end.

If "at the same time" means "individually" then that's probably the cause. The dependencies either need to be already on the DLS or they need to go up in the same package. Simply going up at around the same time (whether before or after) is not sufficient.

chris

whitepass
September 24th, 2015, 10:25 AM
I always upload dependencies first and see if they are good before the "body" upload.