PDA

View Full Version : Nickel Plate DLC does not download for me on Steam



RJArtim
August 16th, 2015, 09:59 AM
I purchased the DLC of the Nickel Plate from Steam and it says it is installed but it never downloaded. It is not in my system. I have the deluxe version of T:ANE and got a 6 month FCT with it. To use that I needed a serial number from Steam and had to add it at the mytrainz site to activate it. I did not get anything for the Nickel Plate DLC. Can anyone help me out here?

shaneturner12
August 16th, 2015, 10:00 AM
Did you purchase T:ANE from Steam as well?

Shane

RJArtim
August 16th, 2015, 10:44 AM
Yes. I bought it the day it was available on Steam

shaneturner12
August 16th, 2015, 10:47 AM
OK - I thought I'd better check as there have been a few issues with people buying the game from Steam and the content from elsewhere (or vice versa).

What should happen (although it sounds like it hasn't on yours for some reason) is that when you load the main game it should download automatically at that point. Does the Steam downloads feature (Library > Downloads) show any downloaded DLC content?

Shane

RJArtim
August 16th, 2015, 11:18 AM
Well it gets worse now. Last night I accidently put my computer in sleep mode and it would not come out of it. I had to pull the plug and let it sit overnight to get my system back. When I started up Steam I had a surprise. First I had to log in, which I have not had to do in years, then I noticed T:ANE and Trainz 2012 were listed as uninstalled even though the files are still on my HD. All my other 213 games on Steam are just fine. Now I had to reinstall T:ANE, fortunately I got Xfinity HI Speed and it only took 15 minutes to dl T:ANE. I bought the Deluxe version for $60 to get the 4 extra routes. The first time around these downloaded and installed when I first started T:ANE up. This time they did not download even after forcing the download several times by using Download Purchased Items.

In the DLC box on Steam it shows I have everything installed. The Nickel Plate and the 4 routes and their dependencies and my FCT. The only thing that is functioning is my FCT. If I uncheck the boxes in the Steam DLC window nothing happens. With any other game this automatically deletes the DLC and rechecking it later on redownloads it. Nothing happens with the T:ANE DLC.

Now I have a big question. I downloaded 108 gig from the DLS, it is in the old folder TA:NE made the first time, can I import all of this into my new download? Would my 4 Deluxe version routes also be in there? I still have not been able to figure out what is where in T:ANE file structure. I have been building trains and routes and scenarios with several other trainsims since 2001 when MSTS came out, so I am not computer illiterate. But T:ANE has been messing with my head since I got it. I have been working on an interactive session, fortunately, I have programming background in BASIC, PASCAL, FORTH, C++, HTML, PHP and Joomla cause you need that mind set to write a session.

And thanks for replying to my plea for help I appreciate it.

shaneturner12
August 16th, 2015, 11:24 AM
They should be, although merging the older content is harder with T:ANE as the files would have to be dragged and dropped into the new folder and a database repair performed from the Developer menu. For the DLC content, this should download when you run the main part of the game.

Shane

RJArtim
August 16th, 2015, 11:45 AM
Well it definitely is not downloading anything. I was waiting for the Nickel Plate to come to Steam, I bought it as soon as it did and still don't have it after 3 days of messing around. In my TANE\crazynumbers folder there is a folder called Packages, I believe this is where the 4 deluxe routes are as they is nothing in that folder of the new build. I will try copying them over and doing the Database rebuild to see if that works. And so far no one else in the Steam forum which is pretty much dead, no one else has posted about the Nickel Plate problem yet either.

shaneturner12
August 16th, 2015, 11:47 AM
Just a thought - have you tried revalidating the T:ANE files in Steam?

Shane

RJArtim
August 16th, 2015, 11:50 AM
Yes, they are 100% OK. That was one of the first things I did.

shaneturner12
August 16th, 2015, 11:52 AM
Something strange is going on in that case. Have you tried contacting N3V's Helpdesk about it? They may have some other ideas that may help.

Shane

RJArtim
August 16th, 2015, 11:55 AM
No have not done the help desk yet and I just copied over the 4 deluxe routes and did the database rebuild and the routes show up but in GREEN and they won't let me run a session, I get a PURCHASE ROUTE link instead. I figured it would be quicker to post in here with all you guys that been doing Trainz forever.

shaneturner12
August 16th, 2015, 11:57 AM
OK - can I check which folder you put the deluxe routes into?

Shane

RJArtim
August 16th, 2015, 12:04 PM
C:\Users\Bob\AppData\Local\N3V Games\TANE\build oqu330ug1\packages

Now in Content Manager it lists the 4 deluxe routes installed but not activated.

shaneturner12
August 16th, 2015, 12:05 PM
That's unusual - it shouldn't be showing it as not activated. Did you get any serial numbers with those routes? If so, it may be worth registering them to your MyTrainz account.

Shane

RJArtim
August 16th, 2015, 12:09 PM
OK I found a file called keystore.tdx in the old folders and moved it over and restarted T:ANE and I have my deluxe routes back, still no Nickel Plate though. I am also getting a warning that the precache data for the deluxe routes did not download.

RJArtim
August 16th, 2015, 12:10 PM
No, no serials number with anything except the FCT

shaneturner12
August 16th, 2015, 12:33 PM
OK - I'm assuming you purchased everything on the same account. If so, it may be worth using the Download Purchased Items option in the File menu on the Launcher then re-starting T:ANE. The next time you go into the game itself after doing this it should have the content available or give you the option to download it. Did you try a database repair? If not, it's worth trying as it can get things back into shape.

Shane

RJArtim
August 16th, 2015, 12:44 PM
I did the download purchased items 20 times already, nothing happens. I have done several database rebuilds, had to, to get the Deluxe routes in. I exported an engine from the old build to the new by making it a cdp file and I rebuilt the database again. Yes the same account I only have 1.

shaneturner12
August 16th, 2015, 12:45 PM
That's very unusual in that case. I've a feeling that N3V need to check that the items are registering properly under your MyTrainz account.

Shane

RJArtim
August 16th, 2015, 12:58 PM
I submitted a help ticket on the Nickel Plate. See what happens...

shaneturner12
August 16th, 2015, 01:01 PM
Hopefully they will be able to sort the problem out for you. Unfortunately, the nature of the problem is not something that I'm going to be able to solve (although I wish I could).

Shane

RJArtim
August 16th, 2015, 01:09 PM
I also have good problem solving abilities, but not this time. I did get my 4 routes back and found a way to get my DLS stuff back with out redownloading it all. Thanks again for your assistance.

shaneturner12
August 16th, 2015, 01:10 PM
That's good - hopefully the remaining issue can be sorted by N3V.

I'm happy to have been able to assist you though.

Shane