PDA

View Full Version : File lock problem



pcas1986
July 21st, 2015, 04:15 AM
I've been getting a few of these:

http://i1188.photobucket.com/albums/z410/casper131/Ashampoo_Snap_2015.07.21_18h33m05s_001_Task%20Comp lete_zpsy3ivv1af.jpg

If I retry after a few seconds, it goes away. It's very random. I wonder if this is related to Andi's route save problem?

WindWalkr
July 21st, 2015, 09:33 AM
If I retry after a few seconds, it goes away. It's very random. I wonder if this is related to Andi's route save problem?

Not really. Similar sort of concept, but different specific problem. A reliable repro would be great, if you find one. It typically requires two systems to be accessing the file in question simultaneously, so for example: submitting an edit to a dependency, which triggers a validation, followed by a modification to the parent itself. This kind of thing is supposed to work itself out in normal circumstances, but there are still problems which we are tracking down.

Just fyi: this level of locking is new in these test builds; it does not exist in live builds.

chris

pcas1986
July 21st, 2015, 06:24 PM
OK, and understood. Getting a repro is likely to be difficult but it occurred during an asset development process that I use frequently. i.e. change something, commit and observe results, test again, etc.

On the first occasion I committed an asset and got the resource lock message. When I committed it again it worked ok.

The problem reoccurred some time later, maybe 30 mins, but this time it took 2-3 retries before the commit worked. There were a few seconds between recommits.

The asset is a test spline (kind track) that has a "wire" attachment as an attached spline. I was playing with it to figure how it worked.

pcas1986
July 22nd, 2015, 04:55 AM
Had a couple more of these today including one that talked about having ten tries to save an asset. Is it worthwhile posting any more pictures?

WindWalkr
July 22nd, 2015, 08:12 AM
Not really, but thanks for the offer :)

chris

andi06
July 22nd, 2015, 08:52 AM
I've also seen this from time to time with various assets. I don't think you are going to find a case that can be reproduced.

Paul, do you have the same asset focused in AssetX? Are there any unsaved alterations or any viewers active?

pcas1986
July 22nd, 2015, 09:04 AM
[QUOTE=andi06;1423959...

Paul, do you have the same asset focused in AssetX? Are there any unsaved alterations or any viewers active?[/QUOTE]

Yes. I'm dragging the asset project from AssetX onto a CM window. If you mean an AssetX viewer such as the IM viewer then that is possible. Generally, the last thing I do is save the config.txt alterations.

Bear in mind that I've done much the same action literally thousands of times before but I don't recall it ever being an issue until this release (77327). When it happens again I'l start snapshotting the AssetX window to see if there is anything common.

andi06
July 22nd, 2015, 09:19 AM
I've no evidence to suggest that this is a factor since AssetX only locks a file when its actually reading or writing and works on data in memory. Dragging and dropping an asset with unsaved changes in AssetX should result in the changes being ignored. Its just a thought.

WindWalkr
July 22nd, 2015, 09:44 AM
This is an internal lock, guys. No other processes can affect it.

chris