PDA

View Full Version : Fatal Error regarding image files



Mick_Berg
June 28th, 2015, 11:26 PM
I got this error which causes the asset to appear in red in Surveyor, and not load.
"- Image file 'br_n2_condenser_late_logo_ramsbottom_art/br_n2_condenser_late_logo_ramsbottom_art_icon.tga' is incorrectly used as both a texture.txt source file and a raw image file."
How would I fix it?
Thanks,
Mick Berg.
PS Is this the right place for error questions?

BuilderBob
June 29th, 2015, 12:42 AM
"- Image file 'br_n2_condenser_late_logo_ramsbottom_art/br_n2_condenser_late_logo_ramsbottom_art_icon.tga' is incorrectly used as both a texture.txt source file and a raw image file."

https://en.wikibooks.org/wiki/Trainz/AM%26C/Fixing_Assets#Error:_Image_file_.27.3Cimage_filena me.3E.27_is_incorrectly_used_as_both_a_texture.txt _source_file_and_a_raw_image_file.

For an icon file, the quick and dirty fix is to remove the image container from the thumbnails container.

The proper fix is to update the image container in the thumbnails container to point to the texture.txt file instead of the .tga file.

Mick_Berg
June 29th, 2015, 11:09 AM
https://en.wikibooks.org/wiki/Trainz/AM%26C/Fixing_Assets#Error:_Image_file_.27.3Cimage_filena me.3E.27_is_incorrectly_used_as_both_a_texture.txt _source_file_and_a_raw_image_file.

For an icon file, the quick and dirty fix is to remove the image container from the thumbnails container.

The proper fix is to update the image container in the thumbnails container to point to the texture.txt file instead of the .tga file.
Thanks for the speedy and clear explanation Bob.
I will let the author know so he can fix these wonderful assets (Gresley N2 locos)
Mick.