PDA

View Full Version : DLS Uploads - Cross Asset Includes



andi06
June 7th, 2015, 10:54 AM
I've had a lot of problems in the past getting assets which use script libraries onto the DLS and it seems to be happening again. The issue comes up on the forums from other authors from time to time. I've just done a very simple update to a build 3.5 Asset which references a script library. The DLS rejected the upload with:


<kuid:122285:79000> : TADGetSpecFromAsset> Unknown asset <kuid:122285:79000>
<kuid:122285:79000> : TADGetSpecFromAsset> no local file available for <kuid:122285:79000>
<kuid2:122285:75001:4> : TrainzBaseSpec::CacheScripts> Syntax error in script of asset '<kuid2:122285:75001:4> "JK Signal Box"'
<kuid2:122285:75001:4> : TrainzBaseSpec::CacheScripts> ** GSC> Could not read file : jkasset.gs.
<kuid2:122285:75001:4> : Could not read file : jkasset.gs.

The last three lines presumably follow on from the fact that the DLS isn't locating the script.

<kuid:122285:79000> is on the DLS in various revisions and the uploaded asset can use any of the versions available. So why can't the DLS find the parent asset.

I tried specifying a revision for the library and the rejection changed to:

<kuid2:122285:79000:3> : TADGetSpecFromAsset> asset <kuid2:122285:79000:3> is not compatible with this version of Trainz
<kuid2:122285:79000:3> : TADGetSpecFromAsset> no local file available for <kuid2:122285:79000:3>

Two questions:

1. What is going on here?
2. Why can't you be more specific about the error to give me a fighting chance of tracking it down?

clam1952
June 7th, 2015, 06:07 PM
Paulsw2 is having a very similar problem in this thread http://forums.auran.com/trainz/showthread.php?120116-Cannot-upload-locos-tender-with-using-the-LilB_loco-gs-script-library
Post Copied below


For those wondering where my reskinned versions of Daniel Gollery's V2 loco have gone (even though the dependencies have uploaded) - I'm getting repeated rejections from the Download Station with variations on the following error message:

<kuid2:103021:100525:20> : TADGetSpecFromAsset> asset <kuid2:103021:100525:20> is not compatible with this version of Trainz
<kuid2:103021:100525:20> : TADGetSpecFromAsset> no local file available for <kuid2:103021:100525:20>
<kuid2:234086:101617:1> : TrainzBaseSpec::CacheScripts> Syntax error in script of asset '<kuid2:234086:101617:1> "LNER/BR Class V2 4200 Gallon Tender - Brunswick Green weathered"'
<kuid2:234086:101617:1> : TrainzBaseSpec::CacheScripts> ** GSC> Could not read file : lilb_loco.gs.
<kuid2:234086:101617:1> : Could not read file : lilb_loco.gs.


I'm trying to upload the locos and tender in build 3.5 (following the DLS roll-back) - is this version compatible with the kuid2:103021:100525:20 version of lilb_loco.gs?

Daniel uploaded his V2's with the kuid2:103021:100525:9 version of the script library and I re-used this in the config for the reskins. Unfortunately, this version was rejected by the DLS.

I should add that both locos and tender with version 20 of the script library work without errors in both TS12 and TANE, so I'm at a loss to understand why the Download Station won't accept them.

Help!

Paul

andi06
June 8th, 2015, 02:40 AM
I've had an email from Helpdesk about this, hopefully a solution is in sight. There have been similar issues in the past.

andi06
June 17th, 2015, 02:24 AM
This is a bump aimed at Zec Murphy - you've gone all quiet on me, has this issue been fixed?

andi06
June 28th, 2015, 09:35 AM
I've received an email from Helpdesk this morning inviting me to complete a satisfaction survey on this ticket. I don't trust myself to fill it in.

Would you please get your fingers out and fix this.