PDA

View Full Version : d3dx9_42.dll



hotgrove
January 17th, 2015, 03:05 PM
I'm sure I've asked about this before but can't find the relevant thread.

Trainz will not open because I don't have d3dx9_42.dll.....can anybody help ?

oknotsen
January 17th, 2015, 03:09 PM
I did a search on d3dx9_42.dll (by simply putting it in the search box) and this seems to be the solution:
You need to install DirectX 09c.

http://forums.auran.com/trainz/showthread.php?113606-missing-dll&highlight=d3dx9_42.dll

hotgrove
January 17th, 2015, 03:25 PM
Thanks for the rapid reply kind sir.....I vaguely remember having this problem before.....I've carried out the instructions but this time my computer is unable to communicate with trainz ?

shaneturner12
January 17th, 2015, 03:39 PM
That would be an unrelated issue. Try restarting your computer as the message states.

Shane

hotgrove
January 17th, 2015, 03:49 PM
Still no change Shane...my computer isn't communicating with trainz ?

shaneturner12
January 17th, 2015, 03:52 PM
OK - I need to check something.

Does this error appear before the Launcher can appear or after you've clicked Start?

Shane

oknotsen
January 17th, 2015, 03:55 PM
Are you running the game as administrator (or was that not relevant for TS2009)?

hotgrove
January 17th, 2015, 03:55 PM
It appears right after I click START.

shaneturner12
January 17th, 2015, 03:56 PM
OK - the likely cause is that your settings in the Trainz Options box have reset. Check these to make sure they are correct for your system.

Also, while you are at it, also check what oknotsen has suggested (which is relevant to all Trainz versions)

Shane

hotgrove
January 17th, 2015, 04:07 PM
Hello Shane....I adjusted my screen res in the options box and I am up and running again although I was able to use the smaller res when taking screenshots.I don't know why it still wouldn't open under that setting.

Anyway the help is much appreciated and the problem appears to be solved.

oknotsen.....thanks for taking the time to help with this issue.....regards hotgrove.

shaneturner12
January 17th, 2015, 04:14 PM
Trainz can be very fickle sometimes. Good to see that the problem is now resolved though.

Shane