PDA

View Full Version : Read-only Route Files



Ryan_McC
December 26th, 2013, 09:47 PM
Hello all

Probably a quick one: I edit a route, go to save changes and the message "Trainz could not overwrite read-only route files. Try saving with a different name." How do I fix this?

Thanks

captainkman
December 26th, 2013, 11:06 PM
Hi there,

This is most likely caused by Trainz being installed in the Program Files folder, which is very heavily guarded by User Account Control.

The way to get around this without moving the Trainz folder or reinstalling is to go to the properties of each Trainz-related .exe file and shortcut, and set it to Run as Administrator. Unfortunately, I forget the details of how to do this as I'm not on a computer right now.

I hope this helps. :)

Kieran.

pware
December 27th, 2013, 01:41 AM
This periodically happens to me as well - since it is not a constant problem every time I save, then I doubt it is entirely a permissions problem. My solution is to select "Save As..." from the main menu. It never occurs on that option.

shaneturner12
December 27th, 2013, 03:28 AM
I can confirm that it's not permissions related, as I also get that periodically and yes I do run as administrator.

The usual effect is that the session does not get saved so you will need to re-use the Save option to save the session.

Shane

Andyz
December 27th, 2013, 03:37 AM
This happens to me on certain routes (typically on the routes that were imported from 2010).
This message is nearly always incorrect, and the route was in fact saved correctly, but the session was not!
The program appears to stumble between saving the route, and saving the session. This appears to be a bug.
But I found a work around solution:

I always select "save route" and "do not save session", this usually saves the route correctly.

Then I select "save" again, and either the session gets saved or I get "your route does not need saving....." (If the session was unchanged).

Selecting "Save As...." Usually Works only until the next time the route is saved. Than the whole story repeats it self.
Also with "Save As" the route is saved with a new Kuid every time, and this orphans all but the current session.

Andyz

JCitron
December 27th, 2013, 09:47 AM
I've gotten this as well and I run as administrator and with the folders outside of C:\Program Files(x86)\.... etc., path.

I just resave what I attempted before and everything seems to be fine. I think it has to do with files handles being open and the program can't access them. I have found that if I wait a few seconds between editing and saving, rather than doing a lot of quick saves, like when you make small changes, I can save with no problem.

John

Ryan_McC
December 28th, 2013, 02:23 AM
Thanks everyone. I edited the route again and saved later in the evening and it worked. Don't know why. I'll keep these tips in mind for next time though.

Pencil42
December 28th, 2013, 01:42 PM
I see this occasionally as well. I just re-save, and the 2nd time it works.

Curtis

Racn
December 30th, 2013, 09:54 AM
I have been seeing that message quite regularly as my route has gotten larger. On one occasion when the save failed I was sent to the select route page, exiting out of game I then found in CM that the route was showing missing dependencies. Got it fixed so all is good again.

carr
December 30th, 2013, 11:19 AM
I also get this message, all I do is to move or add a tree and it saves OK.

JCitron
December 30th, 2013, 11:47 AM
I have been seeing that message quite regularly as my route has gotten larger. On one occasion when the save failed I was sent to the select route page, exiting out of game I then found in CM that the route was showing missing dependencies. Got it fixed so all is good again.

I think this is due to a time-out period during the save and the operating system still has control of the files during the saving process while Trainz its self is trying to close the files again so you can continue with your operations in Surveyor. This causes what is called a file lock. I wonder if we were to watch the TADDaemon command prompt if there is a File-lock attempt! message during this time period.

Although they can be frustrating, file locks are a good thing as they can prevent data corruption should some other program try to manipulate files at the same time as they are being written.

John

commander247
December 30th, 2013, 01:30 PM
I just got the "will not overwrite" message window last night after a few months building a jam-packed 5X5 board route in Tz 12 with narry a problem. I had just adjusted the height of every track in the layout (whew!) when I was notified it wouldn't save. (insert appropriate frowny face here) I did attempt to add on object (tracks layed out to spell an explative expressing my frustration... as a test of course), but that didn't work. After trying all the save, save-as, save one then the other tricks... I turned the computer off before I was tempted to throw it out the window. I have not tried the 'wait and see' trick... but will attempt that tonight... now that my patience has returned to a more normal level.

commander247
December 31st, 2013, 09:40 AM
I solved my problem.

Knowing its more likely human error than a program bug or another software issue and because I’ve used PhotoShop and AfterEffects in my job for years, I figured it was a blunder on my part that caused the “will not overwrite” problem.

So after going back and turning layers on and off to see what was or wasn’t there… I found two pieces of track and a spline point sitting all alone in a session layer.
Removing them and adding them into the route layer (where they should have been) did the trick. Everything saved with no further issues.

I was actually lucky because the misplaced spline point was raised up high because I had been playing with an invisible track for a helicopter path and that spline stuck out like a sore thumb… otherwise, it would have been just a yellow circle at ground level and would have been impossible to find.
The wee hours of the morning and maybe that tumbler of rum didn’t help when I was working on the layout and most likely caused a lapse in concentration when I was editing between sessions and routes. Trainz Surveyor is as finicky as all the other editing programs I use and just likes things to go where they were designed to go and can make your life miserable if you put things in the wrong place. In the end, it all boils down to paying very close attention to the details.

And yes… I did go back and adjust the height on all the couple of hundred track points and the save function didn’t flinch a bit.