PDA

View Full Version : Problems with CJ187's ICE 2 content



Bhorton
July 21st, 2013, 09:53 AM
I am having problems with CJ187's ICE-2 sets, the assets DB-ICE2 - Steuerwagen 21 (2.Kl) & DB-ICE2 - Steuerwagen 31 (2.Kl) will not show up in game, I have tried reverting them, re-committing them, re-installing them, but nothing has happened. Are there any ideas?

Bhorton
July 21st, 2013, 03:52 PM
It is also affecting some of his other content.

shaneturner12
July 21st, 2013, 04:09 PM
Are they showing any errors or missing dependencies?

Shane

mp202
July 21st, 2013, 04:11 PM
I had this problem with his content before... I just waited a while and they finally shown up.

Bhorton
July 22nd, 2013, 01:02 AM
There are no shown errors, and other parts of his ICE-2 train set (all the other carriages) are showing.

p-dehnert
July 22nd, 2013, 02:18 AM
CJ187's assets were created in TS12, and (almost) never tested in any previous version of Trainz. In TS2010 (and TRS2009 ?) his Controlcars (Steuerwagen) need an enginesound. Add the following line to the config.txt
enginesound <kuid2:122285:301:5>
and don't forget to add the kuid to the kuid-table. This is a silent enginesound, other possible (silent) sounds are <kuid2:44700:53770001:1>, <kuid:523:53999> and <kuid:86661:53710>.

Peter

shaneturner12
July 22nd, 2013, 02:18 AM
As BlakeDooley has said, it may be that the assets are slow to appear - especially if they are high poly assets.

Shane

Bhorton
July 22nd, 2013, 11:32 AM
I tried changing the engine sound, but that did not work, and I cannot place it. It does not show the red and green arrows, and does not show up in the rail-yard.

p-dehnert
July 22nd, 2013, 01:58 PM
The config.txt of the Steuerwagen should be changed like the following (additional lines in red).

At the beginning:
kuid <kuid:404575:100837>
username "DB-ICE2 - Steuerwagen 21 (2.Kl)"
category-class "AC"
mass 60000
interior <kuid:404575:100377>
disable-extra-track-sounds 1
engine 1
light_color 255,255,255
ditch_color 255,255,255
enginespec <kuid:404575:100270>
enginesound <kuid2:122285:301:5>
hornsound <kuid:404575:100421>
cabinsway 1
nightmode "constant"


The kuid-table at the end:
kuid-table
{
corona_white <kuid:38427:21013>
corona_red <kuid:38427:21010>
taufe_asset <kuid:404575:100367>
bogey1 <kuid2:404575:100276:1>
cab <kuid:404575:100377>
engine <kuid:404575:100270>
horn <kuid:404575:100421>
passengers <kuid:-3:10060>
enginesound <kuid2:122285:301:5>
}

Peter

Bhorton
July 22nd, 2013, 03:18 PM
I have done that, and there are no warnings or missing dependencies or faulty warnings, and it still does not show up.

Bhorton
July 25th, 2013, 03:48 AM
I had this problem before with cosey's BN tram assets, and (I don't know why), they just randomly started showing. I do not know what could have caused this though.