PDA

View Full Version : SP1 question: Gondolas and KUID2



RacerTodd
May 5th, 2013, 10:11 PM
I have a question concerning the 52ft gondolas and TS12 SP1.

I had installed all the gondolas from the JR site prior to the release of SP1.

Looking in Content Manager, I have 32 of them listed. All have plain KUID numbers. Those show an installation date of Dec 2011.

Most, but not all, have an updated version. Those are dated Sept 2012, presumably that's when I downloaded the updated versions. Those assets now have a KUID2 number, ending in :2

After installing SP1 I noticed some of the gondolas were listed as faulty. I went to the JR site and saw that the gondola page showed that the files were updated 4/11/13, presumably to fix SP1-related issues.

I downloaded and installed the updated files.

Here is my problem: The 4/11/13 updated assets have a KUID2 number that ends in :1.

This means that Trainz uses the :2 version (older) instead of the :1 version (newer). Now, I can delete the :2 versions and Trainz will now use the correct, updated version. BUT - I have a session on the DLS that was made when I had the :2 versions installed. Content Manager now complains that my session has faulty dependencies, since it looks at what it assumes is the latest version (the :2 versions).

Should the gondola updates dated 4/11/13 have had KUID2 numbers ending in :3? That would allow Trainz to use the correct assets and not break any sessions made with the :2 versions.
If they aren't changed to :3 I'm looking at a lot of manual labor trying to re-do my session to use the :1 versions. Since this session is on the DLS, I need to make sure all the people that downloaded it won't have this same issue on their machines.

Todd

leandrobrn
May 8th, 2013, 08:45 PM
I also have this problem.
I did the download again and the error continues.
RBMN Gondola and EMD SD45 - MRL needs update


Everything is in error.

pdkoester
May 8th, 2013, 09:01 PM
Try deleting ONE unit, see what it does. If it achieves what you want, then do the rest of 'em that way. Simple enough. Obviously, you can download it again if you don't get it doing what you want to achieve, at which time then report back here and I or someone else will pop in and advise further.


Paul

RacerTodd
May 8th, 2013, 11:54 PM
Try deleting ONE unit, see what it does. If it achieves what you want, then do the rest of 'em that way. Simple enough. Obviously, you can download it again if you don't get it doing what you want to achieve, at which time then report back here and I or someone else will pop in and advise further.

I can delete the :2 versions of the gons and Content Manager is happy. Problem is the session was created with the :2 versions. The session is fine if the gons are version :3 or later, but can't deal with the fact that I only have the :1 versions in my system.

At this point, the only solution I can come up with is to go manually replace all the gons, which is a pain the rear.

Todd

leandrobrn
May 9th, 2013, 05:52 PM
I managed to solve all problems.