Fatal Error


New member
Not sure if this is the place to put this question, but......

Double-clicking on the TRS 2006 icon on the Desktop after wakening the computer from ‘sleep’ mode, the following message appeared:

A fatal error has occurred

Class: Hardware

Reason: Access violation

Version: Jet vRRRR.RR build 1234.5.qqqq exception@00421.f2f in c.\program files\auran\TRS2006\in\launcher.exe

recoverable exceptions: Yes

Flags: 000

Call stack021f2f

Well, that’s the gist of it. I had been working in Surveyor before closing TRS2006, so all was in order, apparently.

Any experts out there able to help, or will I have to re-install 2006 (and lose all my work?)

Cheers everybody. Barney
That error would not concern me unless it started coming up everytime I tried to open Trainz.
I had a thread called "Yet Another Fatal Error" and the advice I recieved sorted the problem for me and a couple of other people.I"ll bump it up for you.(IN TRS2006)
Last edited:
Thanks for your quick response, Guys.

Yes, Euphod, that's the problem, the program refuses to load. As soon as I try to launch it, this Fatal Error message appears. Don't look too healthy, does it?

This morning when I tried to launch Trainz Classics, it too just froze; no message to say what's wrong, it just sits there with the message saying 'LOADING please wait.'

Looks like I'll hafta go back to basics. Cheers everyone. Barney
It's 10 days since that Fatal Error message appeared. Couldn't get around it, so re-installed the program (after a delay; I couldn't find the program's Key Number) after following rjhowie's advice about copying the Local folder. And do you know what? Everything was back in it's place, as if there'd been no hitches!! Thanks, Bobby, I owe you one. And it's great to have a Forum where you can get help with problems. Cheers everyone. Barney.